Page MenuHomePhabricator

Add a Link makes the pop-up and background screen jerk up and down ... when adding a wikilink in Visual Editor
Closed, ResolvedPublic

Description

When I was writing the geography section of Home Creek, Queensland, I needed to add a number of links to other articles. Which means a number of times the "Add a Link" pop-up appeared. Each time, the pop-up didn't just appear but sort-of bounced into view appearing and then re-appeared slightly higher on the screen (the underlying edit window is scrolling up at the same time, but that's normal).

Now there are two scenarios with using Add a Link, one is that one of the link suggestions is the one you want. → split off to T231376

In the second scenario, the link I want wasn't one of the suggested ones, so I go to the search box in the pop-up to start typing the name of the article I want (I know what it is). On typing the first character, the Add a Link box jerks upwards so its top is hard against the bottom of the VE too bar. Again, annoying but maybe it's trying to create more space below to display suggestions, I think. However as I type each character and it changes its list of suggestions, the Add a Link box is jerking down-and-up a couple of times and the background edit window and the usual Wikipedia left-hand tool bar is also jerking up and down too (but the VE toolbar stays still). This jerking continues until you have typed so much of the name of the desired article that the list of suggestions is small enough to display on screen. For example, if I try to link Patrick to Patrick, Queensland (which is not one of the default suggestions), I have to type every letter of Patrick, Queensland and my screen is jerking about with every letter. I wish I could video it.

This is something that has changed in the past 24 hours. I was writing similar articles yesterday and not observe all this screen jerking going on.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 6 2019, 4:09 AM
matmarex added a subscriber: matmarex.EditedAug 6 2019, 7:02 PM

Thank you for the detailed descriptions. I can reproduce the problems, and I recorded videos of them:

Now there are two scenarios with using Add a Link, one is that one of the link suggestions is the one you want.

→ split off to T231376

In the second scenario, the link I want wasn't one of the suggested ones, so I go to the search box in the pop-up to start typing the name of the article I want (I know what it is). (…) However as I type each character and it changes its list of suggestions, the Add a Link box is jerking down-and-up a couple of times and the background edit window and the usual Wikipedia left-hand tool bar is also jerking up and down too (but the VE toolbar stays still). This jerking continues until you have typed so much of the name of the desired article that the list of suggestions is small enough to display on screen.

I had to zoom in to 125% to reproduce the problem, since on default zoom the list of suggestions was always small enough to display on my screen.

This looks like a conflict between code trying to scroll the entire popup into view, and code trying to scroll the selected text into view.

Change 528877 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[VisualEditor/VisualEditor@master] ve.ui.DesktopContext: Reserve space above anchored inspectors

https://gerrit.wikimedia.org/r/528877

@Kerry_Raymond I'm splitting off your scenario 1 to a separate task T231376, I think that part will take some more effort to solve.

matmarex updated the task description. (Show Details)Aug 27 2019, 7:16 PM
Esanders updated the task description. (Show Details)Aug 28 2019, 12:17 PM

Change 528877 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] ve.ui.DesktopContext: Reserve space above anchored inspectors

https://gerrit.wikimedia.org/r/528877

Change 533346 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (f3f6fae90)

https://gerrit.wikimedia.org/r/533346

Change 533351 had a related patch set uploaded (by DLynch; owner: DLynch):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (f3f6fae90)

https://gerrit.wikimedia.org/r/533351

Change 533351 abandoned by DLynch:
Update VE core submodule to master (f3f6fae90)

Reason:
Duplicate

https://gerrit.wikimedia.org/r/533351

Change 533346 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (4f3a331f6)

https://gerrit.wikimedia.org/r/533346

matmarex moved this task from Inbox to Low Priority on the Editing QA board.Sep 9 2019, 10:58 PM
Ryasmeen edited projects, added Verified; removed Editing QA.Sep 13 2019, 7:33 PM
ppelberg closed this task as Resolved.Oct 23 2019, 1:07 AM
ppelberg claimed this task.

Thanks all, Kerry

Thanks all, Kerry

Thank you for your, clear and thorough reports, Kerry.