Page MenuHomePhabricator

Randomly stuck in saving loop
Closed, ResolvedPublic

Description

Maybe you can guide me into which kind of details would be needed to properly diagnose my issue.
From time to time, when I try to answer comments on Space, I'll get stuck with the blue saving bar at the bottom of the page - it never stops loading no matter how long I leave the tab open, and if I go check my posts, indeed, the affected one is not there.
I have Chrome, FWIW.
I suspected it could be related to poor connection on my side, but this is not the case especially lately, and my Internet seems to be working perfectly well while that one tab doesn't.
Other people seem to be able to answer in the same thread in the meantime.
Retrying won't work for a while. Then, at some point later, it will magically allow me to instantaneously post again.
Help?

If you are having this problem: the thread below elaborated on how it could be related to ad blockers and similar software, and offers solutions.

Event Timeline

Elitre created this task.Aug 7 2019, 10:46 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 7 2019, 10:46 AM

As an example of how random this is, I wasn't able to post a reply in https://discuss-space.wmflabs.org/t/which-kind-of-content-would-you-like-to-find-in-space/759 yesterday, and I am still unable today, but have been able to post on Space somewhere else just minutes ago. WTH!

Same today. Ad has posted some links and I can't reply with a simple Thank you.

This is still happening, and making me sad.

I cleared my cache and will keep you updated on the results.

It didn't change a thing. I was able to post https://discuss-space.wmflabs.org/t/kontor-hamburg-weekly-meetup-august-2019-iv/849 , and now I can't post another one.
I'll note that the spinning thing is already visible while typing, when I have this issue, not just on saving.

Wargo added a subscriber: Wargo.Aug 14 2019, 7:13 AM

Open dev console and see errors.

Open dev console and see errors.

Thanks for the reminder.

There's plenty of errors like the following ones:

/topics/timings:1 Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
2/message-bus/bb664451bcd04384a673f588c6c4ab07/poll:1 Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
/post_actions:1 Failed to load resource: net::ERR_BLOCKED_BY_CLIENT

It appears that I may need to whitelist Space in Adblock. Will try this when I can.

Elitre added a comment.EditedAug 22 2019, 7:26 AM

Maybe that wasn't the reason. I got the issue again while trying to reply to https://discuss-space.wmflabs.org/t/anybody-has-issues-publishing-on-space/850 (!) and my AdBlock is disabled for Space.wmflabs and discuss-space - hence, whitelisted. Ideas?

Qgil triaged this task as Low priority.Aug 22 2019, 2:13 PM
Qgil added a comment.Aug 23 2019, 7:44 AM

OK, I got this problem twice today, and I found a pattern. I bet the root cause of this problem is T228138: Inconsistent enforcement of HTTPS in discuss-space.wmflabs.org.

I got the spinner with Privacy Badger enabled. While the spinner was running, I disabled Privacy Badger for discuss-space, and the process just crashed (no spinner, draft post lost).

With Privacy Badger theoretically disabled, I got the spinner again... Yet in the console I could still see the same errors Failed to load resource: net::ERR_BLOCKED_BY_CLIENT, which clearly points to "a client" blocking what is considered a tracker.

I enabled Privacy Badger again, and checked what it complained about. The "tracker" identified was "discuss-space.wmflabs.org". Because this is the site I was in, the explanation here is a mix of https and http queries, where the http version is considered an external site, a "tracker". Great.

Privacy Badger allows you to manually approve "trackers" detected, which I did for discuss-space. Now Privacy Badger doesn't have any complaints in any discuss-space page, and I bet I will not see the spinner again.

Instead of trying to understand why Privacy Badger or Adblock seem to have problems digesting or ignoring the warnings, I think we should focus on fixing T228138.

Thanks for explaining. I'm looking forward to seeing it fixed so I can come back to Space.

I'd like to acknowledge that I may have figured out what my issue was. I had "just" forgotten that I had actually just installed Privacy Badger. Hence, following your guide should have fixed things now.

If you think there is nothing left to do in this task (?), please feel free to set the task status to invalid via the Add Action...Change Status dropdown. Thanks! :)

Elitre updated the task description. (Show Details)Aug 27 2019, 6:20 PM
Qgil changed the task status from Open to Stalled.Aug 28 2019, 5:39 AM

I will leave report as stalled, to double check it when https works properly.

Qgil closed this task as Resolved.Oct 3 2019, 9:02 PM
Qgil claimed this task.
Qgil edited projects, added Space (Oct-Dec-2019); removed Space.

Now that HTTPS enformcement seems to be fixed, I have re-enabled Privacy Badger for discuss-space, and it shows a beautifully green "0", meaning that now it is not getting confused by http/https inconsistencies.

I bet this problem is fixed now. Resolving. Please reopen if you find an occurrence.

Qgil moved this task from Backlog to Evaluated on the Space (Oct-Dec-2019) board.Mon, Oct 28, 7:56 AM