Page MenuHomePhabricator

Don't show "hide topic" if user lacks the rights
Closed, InvalidPublic

Description

Steps to reproduce:

  • Go to a flow topic
  • Click "hide topic" with an account that lacks the rights to hide a topic
  • Enter reason

Actual result:

  • "Insufficient permissions to execute this action."

Expected result:

  • "Hide topic" button wasn't shown

Aside: this occurred on mediawikiwiki, where * has flow-hide rights - not sure why

Event Timeline

DannyS712 created this task.Aug 8 2019, 5:43 AM
Restricted Application added projects: Growth-Team, User-DannyS712. · View Herald TranscriptAug 8 2019, 5:43 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

@DannyS712 - can you provide a link to the page?

Surprisingly the issue is not reproducible.
What I've tried on mediawiki

  • mediawiki Special:ListGroupRights states that all user have "Hide Structured Discussions topics and posts (flow-hide)"
  • created a new user (with only User group right) - the user was able to hide topic/post in User talk namespace
  • anon user is also able to hide topics
  • when page is protected, there are no 'Hide' option for users who cannot perform editing actions.

@Etonkovidova indeed - I couldn't replicate it either. This was at https://www.mediawiki.org/w/index.php?title=Topic:V502yhwaccxa1e3k (since deleted) - I couldn't hide it, but once someone else did I could unhide it and rehide it. Can you restore the topic?

@DannyS712 - to restore a deleted topic a user needs to have admin rights.

Sorry, I thought all WMF employees had +sysop on mediawiki. I've requested it onwiki - https://www.mediawiki.org/w/index.php?title=Project%3ARequests&type=revision&diff=3350226&oldid=3345361

Wargo added a subscriber: Wargo.Aug 10 2019, 7:02 AM

So you want to disable "hide" for unregistered?

So you want to disable "hide" for unregistered?

No - I was reporting that I was unable to hide the topic despite having the requisite rights. I see that you're an admin on mediawiki - can you restore the topic?

It worked there. But, as I said above

@Etonkovidova indeed - I couldn't replicate it either. This was at https://www.mediawiki.org/w/index.php?title=Topic:V502yhwaccxa1e3k (since deleted) - I couldn't hide it, but once someone else did I could unhide it and rehide it. Can you restore the topic?

It may have been a one-time fluke, but if you could undelete the topic we can see if there was anything different that prohibited me from doing it

Wargo added a comment.Aug 10 2019, 8:27 AM

Analyse history: https://www.mediawiki.org/w/index.php?title=Topic:V502yhwaccxa1e3k&action=history
Someone hide before and your try was also success.

I restored it for test.

I tried to hide it before 94rain, and it didn't work then. I can't replicate it though

kostajh closed this task as Invalid.Aug 19 2019, 12:37 PM
kostajh added a subscriber: kostajh.

I'm closing this but if it becomes reproducible please re-open.