Page MenuHomePhabricator

Create HIDPI logo for Wikidata
Closed, ResolvedPublic

Description

Wikidata does not have a pixel-doubled logo yet.

The English-language SVG logo is at File:Wikidata-logo-en.svg.

Details

Related Gerrit Patches:
operations/mediawiki-config : masterAdd high-density logos for Wikidata
operations/mediawiki-config : masterAdd high-density logos for Wikidata

Event Timeline

Jc86035 created this task.Aug 8 2019, 11:39 AM
matmarex removed a subscriber: matmarex.Aug 8 2019, 6:12 PM
Luke081515 changed the subtype of this task from "Bug Report" to "Task".Aug 27 2019, 1:06 PM

Change 534151 had a related patch set uploaded (by Odder; owner: Odder):
[operations/mediawiki-config@master] Add high-density logos for Wikidata

https://gerrit.wikimedia.org/r/534151

tomasz claimed this task.Sep 3 2019, 1:13 PM

Change 534152 had a related patch set uploaded (by Odder; owner: Odder):
[operations/mediawiki-config@master] Add high-density logos for Wikidata

https://gerrit.wikimedia.org/r/534152

Change 534151 merged by jenkins-bot:
[operations/mediawiki-config@master] Add high-density logos for Wikidata

https://gerrit.wikimedia.org/r/534151

Mentioned in SAL (#wikimedia-operations) [2019-09-04T11:12:39Z] <ladsgroup@deploy1001> Synchronized static/images/project-logos/wikidatawiki-1.5x.png: SWAT: [[gerrit:534151|Add high-density logos for Wikidata (T230120)]] Part I (duration: 00m 56s)

Mentioned in SAL (#wikimedia-operations) [2019-09-04T11:13:59Z] <ladsgroup@deploy1001> Synchronized static/images/project-logos/wikidatawiki-2x.png: SWAT: [[gerrit:534151|Add high-density logos for Wikidata (T230120)]] Part II (duration: 00m 56s)

Elitre removed a subscriber: Elitre.Sep 4 2019, 11:14 AM

Change 534152 merged by jenkins-bot:
[operations/mediawiki-config@master] Add high-density logos for Wikidata

https://gerrit.wikimedia.org/r/534152

Mentioned in SAL (#wikimedia-operations) [2019-09-04T11:18:42Z] <ladsgroup@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:534152|Add high-density logos for Wikidata (T230120)]] (duration: 00m 55s)

Mentioned in SAL (#wikimedia-operations) [2019-09-04T11:24:30Z] <Lucas_WMDE> lucaswerkmeister-wmde@mwmaint1002:~$ printf '%s\n' 'https://en.wikipedia.org/static/images/project-logos/wikidatawiki-1.5x.png' | mwscript purgeList.php wikidatawiki # T230120

The scaling might be a bit off – here’s the page at 200% zoom, with only the 1x CSS rules enabled, the 1.5x CSS rules enabled, and the 2x CSS rules enabled:

tomasz closed this task as Resolved.Sep 4 2019, 11:41 AM
tomasz added a subscriber: Ladsgroup.

This has now very kindly been merged and deployed by @Ladsgroup, thank you ;)

What about my comment above? The logo noticeably shrinks when going from 140% to 150% zoom (and grows again when going back), I don’t think that should happen. (Tested in Firefox – in Chromium, the closest zoom points are 125% and 150%, which is far enough apart that it’s not as noticeable.)

Lydia_Pintscher reopened this task as Open.Sep 4 2019, 4:15 PM
Lydia_Pintscher added a subscriber: Lydia_Pintscher.

Reopening for adressing Lucas' comment.

The logo files themselves seem to be correct – the 1x logo at 200%, the 1.5x logo at 133% (200%/150%) and the 2x logo at 100% look pretty much the same, except that the higher-res versions are less blurry of course. But the stylesheet adds the following rule only to the 1.5x and 2x versions of the logo:

background-size: 135px auto;

I don’t know why that rule is there, but it seems to be the cause for the difference in appearance. If I add it to the 1x logo rule in dev tools, the transition between 140% and 150% looks smooth, at the cost of the logo being smaller than before at 100%.

I think the problem is simply that the Wikidata logo is wider than usual? The 1x PNG is 156px wide, whereas most other logos are 135px. Changing the background-size for the high-res logos to 156px auto also results in consistent scaling, with no change to the 1x logo.

However, the 135px in the CSS are hard-coded in ResourceLoaderSkinModule :/

Edit: kbdwiki, for example, has the opposite problem – their 1x logo is only 113px wide, so the logo appears to grow much larger when going from 140% to 150% zoom.

I did some more digging, and Wikidata is far from the only wiki with this problem – see T232012: Logos that aren’t 135px wide don’t scale correctly at 1.5x and 2x resolutions. Not sure if it makes sense to keep this issue open in that case – what do you think, Lydia?

tomasz removed tomasz as the assignee of this task.Sep 5 2019, 4:42 PM
tomasz added a subscriber: tomasz.
tomasz removed a subscriber: tomasz.Sep 5 2019, 4:50 PM
Lydia_Pintscher closed this task as Resolved.Sep 5 2019, 6:06 PM
Lydia_Pintscher claimed this task.

Alright :)