Page MenuHomePhabricator

Clean up `wgNamespacesToBeSearchedDefault` to remove unneeded entries
Closed, ResolvedPublic

Description

By default (DefaultSettings.php), wgNamespacesToBeSearchedDefault only includes NS_MAIN

In initialize settings, wmf sites are set to have NS_MAIN (0) as true (1), and then namespaces 1 through 13 as false (0). Individual sites set additional namespaces to be false, despite those namespaces never having been included in the namespaces to be searched. These entries are extraneous and should be removed, both for code readability and because they unnecessarily bloat the size of InitialiseSettings.php.

Event Timeline

Restricted Application added a project: User-DannyS712. · View Herald TranscriptAug 20 2019, 12:37 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 531172 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[operations/mediawiki-config@master] Clean up wgNamespacesToBeSearchedDefault to remove unneeded entries

https://gerrit.wikimedia.org/r/531172

DannyS712 added a project: User-Urbanecm.
DannyS712 moved this task from Backlog to To deploy on the User-Urbanecm board.

Change 531172 merged by jenkins-bot:
[operations/mediawiki-config@master] Clean up wgNamespacesToBeSearchedDefault to remove unneeded entries

https://gerrit.wikimedia.org/r/531172

Change 531321 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Revert "Clean up wgNamespacesToBeSearchedDefault to remove unneeded entries"

https://gerrit.wikimedia.org/r/531321

Change 531321 merged by Urbanecm:
[operations/mediawiki-config@master] Revert "Clean up wgNamespacesToBeSearchedDefault to remove unneeded entries"

https://gerrit.wikimedia.org/r/531321

Reverted due to T230847: Logstash missing most messages from mediawiki (Aug 2019) - I'm not sure I understand the relationship?

I can't deploy things safely unless I see the logs. Your patch isn't (and can't, it didn't see prod) the cause, it just can't be deployed, so I reverted it.

I can't deploy things safely unless I see the logs. Your patch isn't (and can't, it didn't see prod) the cause, it just can't be deployed, so I reverted it.

Thanks for the explanation - no worries. I was just confused. I don't have access to logstash or anything, so I'm not aware of how the back-end works

DannyS712 changed the task status from Open to Stalled.Aug 21 2019, 12:13 AM

Waiting for T230847 to be solved

Urbanecm changed the task status from Stalled to Open.Aug 21 2019, 10:02 AM

No need to stall, it seems to be back in normal, just pending investivation, which is not a blocker.

Change 531501 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Revert "Revert "Clean up wgNamespacesToBeSearchedDefault to remove unneeded entries""

https://gerrit.wikimedia.org/r/531501

Change 531501 merged by jenkins-bot:
[operations/mediawiki-config@master] Revert "Revert "Clean up wgNamespacesToBeSearchedDefault to remove unneeded entries""

https://gerrit.wikimedia.org/r/531501

Urbanecm closed this task as Resolved.Aug 22 2019, 11:24 PM