Page MenuHomePhabricator

Links in hovercards don't work in the Georgian Wikipedia
Open, NormalPublic

Description

To reproduce:

  1. Open an anonymous desktop browser window.
  2. Go to https://ka.wikipedia.org/wiki/ABBA .
  3. Hover over a blue link. A popup appears.
  4. Click the blue link at the bottom of the popup.

Observed: A page opens saying that the page doesn't exist.

Expected: An article page is supposed to open.

The likely reason for this bug is probably the Georgian alphabet Unicode capitalization issue, which is described in T230559 and T208139. The solution proposed by @Esanders in T230559 may also fix this bug, but I'm creating a separate task anyway because it's conceivable that that there is another JavaScript issue.

Event Timeline

Amire80 created this task.Tue, Aug 20, 3:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptTue, Aug 20, 3:01 PM
Jdlrobson added a project: Readers-Web-Backlog.
Jdlrobson added a subscriber: Jdlrobson.

Not sure if this is an issue with Page previews or the API (or both)

Once mw.Title has done the normalisation incorrectly I think neither are to blame :)

Jdlrobson changed the task status from Open to Stalled.Tue, Aug 27, 9:36 PM

Per @Esanders suggestion I'd suggest we see how we can help editing with T230559 per the suggestion in description. This task should be stalled on that.

Possibly fixed. We'll be able to test and verify this on Thursday.

Jdlrobson changed the task status from Stalled to Open.Fri, Sep 13, 12:04 AM

This doesn't seem to have been fixed. Needs further investigation.