Page MenuHomePhabricator

Labels for newly-added values don't show up as links
Closed, ResolvedPublicBUG REPORT

Description

UPDATE: This is now present on production but appears fixed on Beta, so the patch should be forthcoming.

User story: N/A

We have this:

On Beta, when adding new SD values via either UploadWizard or File page, the labels for the entities don't turn into links to the respective pages for that entity on Wikidata. On file page, the proper links appear upon refresh after they've been published.

Everything is fine on production though.

We want this:

Beta functionality needs to work as it does on prod.

Screenshots (if possible):

File page:

Upload Wizard:

Acceptance Criteria:

  • Links for entities on Beta appear as soon as the entity is selected from the autosuggest box
  • Links on entities remain present after "publishing"

During development, please test the following:

  • Test this feature while logged in AND logged out
  • Test this feature on at least one mobile browser
  • Test that this feature works on the file page AND the Add Data step on UploadWizard (if applicable, some features only exist on one or the other)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 21 2019, 12:03 AM

Feel free to throw this over to Matthias if you don't have the bandwidth 😈

Just want to confirm that I can reproduce this locally – the problem is not limited to Beta.

Merged some patches yesterday that should have addressed this. Just went to a random file on Beta commons and added a new value; it's label was properly linked from the moment it was added. Please double-check but I think this is fixed.

Ramsey-WMF renamed this task from [Beta Commons] Labels for newly-added values don't show up as links to Labels for newly-added values don't show up as links.Aug 26 2019, 11:44 PM
Ramsey-WMF triaged this task as Normal priority.
Ramsey-WMF updated the task description. (Show Details)

Seems fine on Beta, but now that the bug is present on production as well, need to verify this fix makes it to prod.

Ramsey-WMF closed this task as Resolved.Sep 9 2019, 4:21 PM

Tested on Prod and works (plus Eric and Matthias swear it's fixed).