Page MenuHomePhabricator

New lexemes missing in Wikidata Query Service
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

Go to https://query.wikidata.org/#DESCRIBE%20wd%3AL60296

Press blue button

Actual Results:

"No matching records found"

Expected Results:

Results should be found as the lexeme is available at: https://www.wikidata.org/wiki/Lexeme:L60296

wd:L60174 is there (~2019-08-21 13:13 UTC) while wd:L60174 is not there (019-08-31 14:16). Something must have happen in the afternoon.

Event Timeline

Fnielsen created this task.Aug 22 2019, 6:50 AM
Restricted Application added a project: Wikidata. · View Herald TranscriptAug 22 2019, 6:50 AM

We're getting:

wdq6: 17:16:23.890 [update 0] WARN  org.wikidata.query.rdf.tool.Updater - Contained error syncing.  Giving up on L60296
org.wikidata.query.rdf.tool.exception.ContainedException: RDF parsing error for https://www.wikidata.org/wiki/Special:EntityData/L60296.ttl?flavor=dump&nocache=1566494183408
	at org.wikidata.query.rdf.tool.wikibase.WikibaseRepository.collectStatementsFromUrl(WikibaseRepository.java:401)
	at org.wikidata.query.rdf.tool.wikibase.WikibaseRepository.fetchRdfForEntity(WikibaseRepository.java:457)
	at org.wikidata.query.rdf.tool.wikibase.WikibaseRepository.fetchRdfForEntity(WikibaseRepository.java:433)
	at org.wikidata.query.rdf.tool.Updater.handleChange(Updater.java:362)
	at org.wikidata.query.rdf.tool.Updater.lambda$handleChanges$0(Updater.java:236)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)
Caused by: org.openrdf.rio.RDFParseException: Default namespace used but not defined [line 42]
	at org.openrdf.rio.helpers.RDFParserHelper.reportFatalError(RDFParserHelper.java:440)
	at org.openrdf.rio.helpers.RDFParserBase.reportFatalError(RDFParserBase.java:685)
	at org.openrdf.rio.turtle.TurtleParser.reportFatalError(TurtleParser.java:1405)
	at org.openrdf.rio.helpers.RDFParserBase.getNamespace(RDFParserBase.java:342)
	at org.openrdf.rio.turtle.TurtleParser.parseQNameOrBoolean(TurtleParser.java:1032)
	at org.openrdf.rio.turtle.TurtleParser.parseValue(TurtleParser.java:643)
	at org.openrdf.rio.turtle.TurtleParser.parseSubject(TurtleParser.java:474)
	at org.openrdf.rio.turtle.TurtleParser.parseTriples(TurtleParser.java:407)
	at org.openrdf.rio.turtle.TurtleParser.parseStatement(TurtleParser.java:259)
	at org.openrdf.rio.turtle.TurtleParser.parse(TurtleParser.java:214)
	at org.wikidata.query.rdf.tool.wikibase.WikibaseRepository.collectStatementsFromUrl(WikibaseRepository.java:392)
	... 8 common frames omitted

So that's why it's not updated. I'll check why this happens.

RDF generated is:

:L60296 a ontolex:LexicalEntry ;
	rdfs:label "zimangiran"@ku ;
	wikibase:lemma "zimangiran"@ku ;
	dct:language :Q36368 ;
	wikibase:lexicalCategory :Q34698 ;
	ontolex:lexicalForm :L60296-F1,
		:L60296-F2,
		:L60296-F3 .

I think it relates to some recent RDF patches. Maybe lexeme module needs updates. @WMDE-leszek could you check?

Smalyshev triaged this task as Unbreak Now! priority.Aug 22 2019, 5:19 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptAug 22 2019, 5:19 PM

Change 531731 had a related patch set uploaded (by Smalyshev; owner: Smalyshev):
[mediawiki/extensions/WikibaseLexeme@master] Fix Lexemes RDF generation

https://gerrit.wikimedia.org/r/531731

Change 531759 had a related patch set uploaded (by Smalyshev; owner: Smalyshev):
[mediawiki/extensions/WikibaseLexeme@wmf/1.34.0-wmf.19] Fix Lexemes RDF generation

https://gerrit.wikimedia.org/r/531759

Change 531731 merged by Smalyshev:
[mediawiki/extensions/WikibaseLexeme@master] Fix Lexemes RDF generation

https://gerrit.wikimedia.org/r/531731

Change 531759 merged by Urbanecm:
[mediawiki/extensions/WikibaseLexeme@wmf/1.34.0-wmf.19] Fix Lexemes RDF generation

https://gerrit.wikimedia.org/r/531759

Mentioned in SAL (#wikimedia-operations) [2019-08-22T23:41:41Z] <urbanecm@deploy1001> Synchronized php-1.34.0-wmf.19/extensions/WikibaseLexeme: SWAT: e4a5457: Fix Lexemes RDF generation (T230974) (duration: 00m 49s)

Smalyshev lowered the priority of this task from Unbreak Now! to Normal.Aug 22 2019, 11:43 PM

Immediate RDF breakage fixed, now I'll have to update lexemes that were affected.

Smalyshev closed this task as Resolved.Aug 23 2019, 12:06 AM
Smalyshev claimed this task.

All should be updated now.