Page MenuHomePhabricator

Cannot import because of interaction between title change and summary field?
Closed, DeclinedPublic5 Story PointsBUG REPORT

Description

Steps to reproduce:

At this point, if you populate the summary again you'll be sent to the title change dialog a second time, and this loop will repeat if the same steps are taken. Leaving the edit summary blank allows "Import" to actually import.

Acceptance Criteria

  • When a file's name is automatically changed to the accurate file ending (e.g. it was called "png", but it is actually "jpeg", and thus we changed it), this has no effect on any other part of the interaction.
    • Specifically, the edit summary should stay intact, be changable, and no import should be blocked.

Notes

  • This should probably contain a regression test

Event Timeline

awight created this task.Aug 22 2019, 9:53 AM
Restricted Application added a project: TCB-Team. · View Herald TranscriptAug 22 2019, 9:53 AM
awight changed the subtype of this task from "Task" to "Bug Report".Aug 22 2019, 9:53 AM

I tried reproducing, but the file now has a licence that does not allow a transfer to Commons, so not possible :/

The same also works on commons with the "normal" title change page.

Lea_WMDE set the point value for this task to 5.
awight updated the task description. (Show Details)Aug 30 2019, 9:56 AM

I couldn't reproduce this, so will postpone for the moment.

awight closed this task as Declined.Sep 9 2019, 9:28 AM

In fact, closing until we see this happening again.