Page MenuHomePhabricator

DefaultPreferencesFactory.php: Global default '' is invalid for field incubatortestwiki-code
Closed, DeclinedPublic

Description

Error

Request ID: XV65fApAMFMAAHcH1LUAAABN
Request URL: incubator.wikimedia.org/wiki/Special:Preferences

message
[XV65fApAMFMAAHcH1LUAAABN] /wiki/Special:Preferences   MWException from line 235 of /srv/mediawiki/php-1.34.0-wmf.19/includes/preferences/DefaultPreferencesFactory.php: Global default '' is invalid for field incubatortestwiki-code
trace
#0 /srv/mediawiki/php-1.34.0-wmf.19/includes/preferences/DefaultPreferencesFactory.php(185): MediaWiki\Preferences\DefaultPreferencesFactory->loadPreferenceValues(User, RequestContext, array)
#1 /srv/mediawiki/php-1.34.0-wmf.19/extensions/GlobalPreferences/includes/GlobalPreferencesFactory.php(131): MediaWiki\Preferences\DefaultPreferencesFactory->getFormDescriptor(User, RequestContext)
#2 /srv/mediawiki/php-1.34.0-wmf.19/includes/preferences/DefaultPreferencesFactory.php(1495): GlobalPreferences\GlobalPreferencesFactory->getFormDescriptor(User, RequestContext)
#3 /srv/mediawiki/php-1.34.0-wmf.19/includes/specials/SpecialPreferences.php(113): MediaWiki\Preferences\DefaultPreferencesFactory->getForm(User, RequestContext, string)
#4 /srv/mediawiki/php-1.34.0-wmf.19/includes/specials/SpecialPreferences.php(90): SpecialPreferences->getFormObject(User, RequestContext)
#5 /srv/mediawiki/php-1.34.0-wmf.19/includes/specialpage/SpecialPage.php(571): SpecialPreferences->execute(NULL)
#6 /srv/mediawiki/php-1.34.0-wmf.19/includes/specialpage/SpecialPageFactory.php(582): SpecialPage->run(NULL)
#7 /srv/mediawiki/php-1.34.0-wmf.19/includes/MediaWiki.php(296): MediaWiki\Special\SpecialPageFactory->executePath(Title, RequestContext)
#8 /srv/mediawiki/php-1.34.0-wmf.19/includes/MediaWiki.php(892): MediaWiki->performRequest()
#9 /srv/mediawiki/php-1.34.0-wmf.19/includes/MediaWiki.php(523): MediaWiki->main()
#10 /srv/mediawiki/php-1.34.0-wmf.19/index.php(42): MediaWiki->run()
#11 /srv/mediawiki/w/index.php(3): require(string)
#12 {main}
Impact

7 hits in the last hour, 23 in the last 24 hours, not seen before that.

A few started at 2019-08-25T18:00 , then we get a constant stream of them since 2019-08-26T09:40:00

Notes

Blocking next week's train.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 22 2019, 4:35 PM
zeljkofilipin triaged this task as Unbreak Now! priority.Aug 22 2019, 4:36 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptAug 22 2019, 4:36 PM
Restricted Application added a project: Community-Tech. · View Herald TranscriptAug 22 2019, 4:44 PM

Friendly reminder, this is blocking the train. Will it be resolved by train window tomorrow?

Working on it, however there were no changes to WikimediaIncubator, GlobalPreferences or relevant parts of core recently, so I don't think this should be a blocker.

Change 532501 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[mediawiki/core@master] Add more information to exception thrown

https://gerrit.wikimedia.org/r/532501

Change 532501 merged by jenkins-bot:
[mediawiki/core@master] Add more information to exception thrown

https://gerrit.wikimedia.org/r/532501

Working on it, however there were no changes to WikimediaIncubator, GlobalPreferences or relevant parts of core recently, so I don't think this should be a blocker.

This is creating log spam, that's why I've reported it. All new errors are by default blocking the train.

hashar updated the task description. (Show Details)Aug 27 2019, 2:06 PM
aezell added a subscriber: aezell.Aug 27 2019, 5:58 PM

I'm not sure if this was clear but when talking to @MaxSem, he told me that he has been unable to reproduce this error. That's one reason why we are pursuing other ways to get more information and/or work around it in the short term.

Ebe123 added a subscriber: Ebe123.Aug 28 2019, 4:16 PM
MaxSem lowered the priority of this task from Unbreak Now! to Medium.Aug 28 2019, 7:13 PM

No errors this week, not an UBN.

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:06 PM
Krinkle closed this task as Declined.Oct 17 2019, 6:29 PM
Krinkle added a subscriber: Krinkle.

No longer seen. Most certainly not fixed, but also not actionable until it happens. Closing for now and removing from the exclusion list of tolerated prod errors in the Logstash filters.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptOct 17 2019, 6:29 PM