Page MenuHomePhabricator

Specific problems with account "User:Tulsi Bhagat"
Closed, ResolvedPublic

Description

Hello there,

I don't know what's wrong with my account "User:Tulsi Bhagat". Please help me.

Problems

  1. Other review tools is not appearing on various Indic language wikis such as ne.wiki, bh.wiki, hi.wiki and so on.
  2. Editing toolbar is not appearing at ne.wiki.

Screenshots


What i did?

  1. tried resetting the preferences
  2. clearing caches
  3. using different web browsers

Kind regards,
Tulsi

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFri, Aug 23, 6:37 AM
Aklapper changed the task status from Open to Stalled.Fri, Aug 23, 8:58 AM

Hi, I assume this is about https://ne.wikipedia.org (please include links that allow someone to reproduce).
Please see and follow https://www.mediawiki.org/wiki/Help:Locating_broken_scripts

Krinkle updated the task description. (Show Details)Fri, Aug 23, 3:29 PM
Krinkle added a subscriber: Krinkle.EditedFri, Aug 23, 3:32 PM

It works for me at action=edit.

Try adding &safemode=on to the address bar, and reload the page. Does it now work? If so, then it is likely due to a problem with a gadget or user script.

To find out which one is the issue, disable all gadgets, and then slowly re-enable them and test each time. To disable user scripts, make the User:name/common.js and User:name/vector.js pages empty.

It works for me at action=edit.


Try adding &safemode=on to the address bar, and reload the page. Does it now work? If so, then it is likely due to a problem with a gadget or user script.
To find out which one is the issue, disable all gadgets, and then slowly re-enable them and test each time. To disable user scripts, make the User:name/common.js and User:name/vector.js pages empty.


Nope still not working. Each and every gadget is turned off. User:name/common.js and User:name/vector.js pages are deleted.

@Tulsi_Bhagat: Are there errors shown in the "Console" of the "Developer Tools" when you do not see the editing toolbar?

Tulsi_Bhagat updated the task description. (Show Details)Sat, Aug 24, 2:07 PM
Aklapper changed the task status from Stalled to Open.Sat, Aug 24, 2:33 PM
Aklapper added a project: WikiEditor.

@Aklapper: Please also note that "Other review tools" is also not showing.

@Tulsi_Bhagat Thanks. The following console error is the root cause of the problems you have been seeing:

exception: URI malformed URIError: URI malformed
    at decodeURIComponent (<anonymous>)
    at decoded (<anonymous>:8:388)
    at Function.$.cookie (<anonymous>:9:261)
    at Object.buildSection (https://ne.wikipedia.org/w/load.php?lang=ne&modules=ext.wikiEditor&skin=vector&version=1koyjm7:25:650)

It looks like something (possibly a gadget, user script, or browser extension) has stored a cookie value on your computer with incorrect text encoding. As such, none of the JavaScript-based tools (including the editor) are able to read which cookies are set, and then most other things fail after that.

If you type the following in the console and then press Enter, it will show all currently set cookies:

document.cookie

For example, for me it shows:

"GeoIP=GB:ENG:<a city><some coordinates>:v4; mwPhp7Seed=f57;"

It would help if you could share this so that I can help find which tool has caused the problem. If you recognise anything personal like a city or GPS coordinates, these should be removed. If you're unsure or want to be extra safe, you may e-mail to me via ttijhof@wikimedia.org and mention T231061 (this task).

Alternatively, if you just want to get everything working again, you can also go to chrome://settings/siteData in the address bar to clear the cookies on one website (ne.wikipedia.org and wikipedia.org). However, the problem might come back at some point..

@Krinkle: So, the output i got is

"mbNamespaces=%u0935%u093F%u0936%u0947%u0937%3A%u092A%u094D%u0930%u092F%u094B%u0917%u0915%u0930%u094D%u0924%u093E%3A%u092A%u094D%u0930%u092F%u094B%u0917%u0915%u0930%u094D%u0924%u093E%20%u0935%u093E%u0930%u094D%u0924%u093E%3AContributions%7CContribs; GeoIP=NP:1:city:XX.XX:XX.XX:v4; mwPhp7Seed=600; VEE=wikitext"

And, after clearing the cookies, "Editing toolbar" seems working fine now, but "Other review tools" is still not working. Additional, Console logs are still getting that "URIError: URI malformed" errors.

Oh god, What's wrong? "Editing toolbar" is not working again. :/

OK. So the invalid cookie statement is likely mbNamespaces.

Looking on ne.wikipedia.org, I don't find anything.

Looking globally, I find various copies of "MediaWiki:Gadget-markblocked.js" that create a cookie with this name. That's likely where it comes from. And your global.js installs this gadget.

I've made a change to this gadget, that I hope fixes the issue. (You'll have to clear local cookies again)

Tulsi_Bhagat closed this task as Resolved.Sat, Aug 31, 1:25 PM
Tulsi_Bhagat claimed this task.

Thank you Krinkle! :D

Tulsi_Bhagat awarded a token.
happy5214 moved this task from Backlog to Closed on the WikiEditor board.Sun, Sep 8, 12:46 PM