Page MenuHomePhabricator

No edit pencil on edit cards when tapping on that node for the second time
Closed, ResolvedPublic

Description

Steps to replicate:

  1. Open the editor, tap on a link, it shows the edit card with edit pencil icon to edit.

  1. Cross it out, tap the link again it selects the link text instead of showing edit card, it shows the keyboard to edit the label.

  1. Tap on the check icon on the toolbar.
  1. Tap on the link again, this time it shows edit card without any pencil icon.

I'm not sure why we have three different behaviors for the same action. Are any of these intentional?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFri, Aug 23, 11:27 PM
Ryasmeen renamed this task from No edit pencil on edit card for links to No edit pencil on edit cards when tapping on that node for the second time.EditedFri, Aug 23, 11:41 PM

This actually happens for all cases when you close the edit card and tap again to reopen it and also immediately after adding a link.

Edit card for map with no buttons to edit:

Esanders added a subscriber: Esanders.EditedSun, Aug 25, 1:07 PM

This looks like an iOS browser bug, although I can't reproduce it on my devices.

This looks like an iOS browser bug, although I can't reproduce it on my devices.

@Esanders: Yeah, I think you are right, I am also not being able to reproduce it after upgrading the iOS. Will close this for now.

Ryasmeen closed this task as Resolved.Mon, Aug 26, 5:00 PM
Ryasmeen claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMon, Aug 26, 5:00 PM