Page MenuHomePhabricator

Wrong file page URL on the overlay at caption editing task in Android app
Closed, ResolvedPublicBUG REPORT

Description

Tested with latest stable (2.7.50287-r-2019-08-01) and latest alpha version (2.7.50289-alpha-2019-08-23).

Steps to Reproduce:

  1. Set primary Wikipedia language to something other than English (tested with Hungarian).
  2. Open Suggested edits from the hamburger menu.
  3. Tap Add image captions.
  4. Tap Add caption to whatever image comes up.
  5. Tap the info bar at the bottom of the screen.
  6. Tap File page on Wikimedia Commons.

Actual Results:
The opening link is something like https://commons.wikimedia.org/wiki/Fájl:SA106 1 5 16 Grudziadz.JPG, with localised namespace name.

Expected Results:
The namespace is not localised, as Commons understands only the English one.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript
ABorbaWMF added a subscriber: ABorbaWMF.

Looking good to me on 2.7.50290-alpha-2019-08-27

Yes, the bug seems to be gone. It would be useful to know the cause, though…

Charlotte triaged this task as Medium priority.Oct 8 2019, 5:05 PM
Dbrant closed this task as Resolved.Nov 1 2019, 2:22 PM