Page MenuHomePhabricator

DBQueryError from ExternalStoreDB::fetchBlob: Table 'enwiki.blobs' doesn't exist
Closed, ResolvedPublic

Description

After 45831e6 was merged, https://en.wikipedia.beta.wmflabs.org/wiki/Main_Page started to say:

Original exception: [XWKYxqwQBHcAAHEcZAYAAAAO] /wiki/Main_Page Wikimedia\Rdbms\DBQueryError from line 1587 of /srv/mediawiki/php-master/includes/libs/rdbms/database/Database.php: A database query error has occurred. Did you forget to run your application's database schema updater after upgrading? 
Query: SELECT blob_text FROM `blobs` WHERE blob_id = '111937' LIMIT 1 
Function: ExternalStoreDB::fetchBlob
Error: 1146 Table 'enwiki.blobs' doesn't exist (172.16.5.170:3306)

After reverting 45831e6 on beta, all started to work.

Event Timeline

Urbanecm triaged this task as Unbreak Now! priority.Sun, Aug 25, 2:20 PM
Urbanecm created this task.
Restricted Application added subscribers: Liuxinyu970226, Aklapper. · View Herald TranscriptSun, Aug 25, 2:20 PM
Urbanecm removed the point value for this task.Sun, Aug 25, 2:20 PM

Mentioned in SAL (#wikimedia-cloud) [2019-08-25T16:33:34Z] <Urbanecm> Revert 45831e6 locally on beta cluster to test possible root cause of T231162

Urbanecm renamed this task from Beta cluster is down to Table 'enwiki.blobs' doesn't exist thrown on beta after 45831e6.Sun, Aug 25, 4:38 PM
Urbanecm updated the task description. (Show Details)

Change 532248 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[mediawiki/core@master] Revert "rdbms: make LoadBalancer::reallyOpenConnection() handle setting DBO_TRX"

https://gerrit.wikimedia.org/r/532248

Krinkle assigned this task to aaron.Sun, Aug 25, 4:40 PM
Krinkle lowered the priority of this task from Unbreak Now! to Low.
Restricted Application added a project: Core Platform Team. · View Herald TranscriptSun, Aug 25, 4:40 PM
Rxy removed aaron as the assignee of this task.Sun, Aug 25, 4:40 PM
Rxy raised the priority of this task from Low to Unbreak Now!.
Rxy added a project: MediaWiki-General.
Rxy added a subscriber: aaron.

Immediate issue is resolved in master and beta (prod was not yet affected). Assigning to patch author as low-prio to solve in a re-submission.

Krinkle assigned this task to aaron.Sun, Aug 25, 4:41 PM
Krinkle lowered the priority of this task from Unbreak Now! to Low.

I assume that was an edit conflict :)

Krinkle renamed this task from Table 'enwiki.blobs' doesn't exist thrown on beta after 45831e6 to DBQueryError from ExternalStoreDB::fetchBlob: Table 'enwiki.blobs' doesn't exist.Sun, Aug 25, 4:41 PM
Krinkle removed a project: Patch-For-Review.

Mentioned in SAL (#wikimedia-releng) [2019-08-25T16:43:28Z] <Urbanecm> Revert 'Revert 45831e6 locally on beta cluster to test possible root cause of T231162'

Change 532248 merged by jenkins-bot:
[mediawiki/core@master] Revert "rdbms: make LoadBalancer::reallyOpenConnection() handle setting DBO_TRX"

https://gerrit.wikimedia.org/r/532248

kchapman moved this task from Inbox to Doing on the Performance-Team board.Mon, Aug 26, 8:15 PM

Change 532551 had a related patch set uploaded (by Aaron Schulz; owner: Aaron Schulz):
[mediawiki/core@master] externalstore: deprecate getLBInfo() dependency in ExternalStoreDB

https://gerrit.wikimedia.org/r/532551

Change 532551 merged by jenkins-bot:
[mediawiki/core@master] externalstore: deprecate getLBInfo() dependency in ExternalStoreDB

https://gerrit.wikimedia.org/r/532551

aaron closed this task as Resolved.Thu, Sep 12, 7:24 AM