Page MenuHomePhabricator

Upgrade Heritage to PHP 7
Closed, ResolvedPublic

Description

The Heritage API currently works with PHP 5.6 ; Toolforge supports PHP 7 so let’s upgrade.

Details

Related Gerrit Patches:
labs/tools/heritage : masterSwitch API to use PHP 7.2

Related Objects

Event Timeline

Change 532229 had a related patch set uploaded (by Jean-Frédéric; owner: Jean-Frédéric):
[labs/tools/heritage@master] Switch API to use PHP 7.2

https://gerrit.wikimedia.org/r/532229

Change 532229 merged by jenkins-bot:
[labs/tools/heritage@master] Switch API to use PHP 7.2

https://gerrit.wikimedia.org/r/532229

Mentioned in SAL (#wikimedia-cloud) [2019-08-26T21:16:03Z] <JeanFred> T231223: webservice php5.6 stop ; webservice --backend=kubernetes php7.2 start

@JeanFred was there anything left to do on this one?

JeanFred closed this task as Resolved.Jan 14 2020, 11:03 PM
JeanFred claimed this task.

Nope, let’s close :)