Page MenuHomePhabricator

Lexeme tests produce errors on merge
Closed, ResolvedPublic

Description

When trying to merge Wikibase patches ([[ 04:44:23 There were 3 errors:
04:44:23
04:44:23 1) Wikibase\Lexeme\Tests\MediaWiki\Diff\LexemeDiffVisualizerIntegrationTest::testChangedLexicalCategoryItemsUseLabelsFromLanguageFallback | example ]]), we get:

04:44:23 There were 3 errors:
04:44:23 
04:44:23 1) Wikibase\Lexeme\Tests\MediaWiki\Diff\LexemeDiffVisualizerIntegrationTest::testChangedLexicalCategoryItemsUseLabelsFromLanguageFallback
04:44:23 Hamcrest\AssertionError: Expected: is valid html piece having child (with tag name "del" and having child having text contents "noun" and having child (tag matching outline `<sup class="wb-language-fallback-indicator"/>`  and having text contents "ENGLISCH"))
04:44:23      but: valid html piece having no children (with tag name "del" and having child having text contents "noun" and having child (tag matching outline `<sup class="wb-language-fallback-indicator"/>`  and having text contents "ENGLISCH"))
04:44:23 Actual html:
04:44:23 <tr><td colspan="2" class="diff-lineno">lexical category</td><td colspan="2" class="diff-lineno">lexical category</td></tr><tr><td class="diff-marker">-</td><td class="diff-deletedline"><div><del class="diffchange diffchange-inline"><span><a title="Item:Q2" href="/index.php/Item:Q2" lang="en">noun</a><sup class="wb-language-fallback-indicator">Englisch</sup></span></del></div></td><td class="diff-marker">+</td><td class="diff-addedline"><div><ins class="diffchange diffchange-inline"><span><a title="Item:Q3" href="/index.php/Item:Q3" lang="en">verb</a><sup class="wb-language-fallback-indicator">Englisch</sup></span></ins></div></td></tr>
04:44:23 
04:44:23 /workspace/src/vendor/hamcrest/hamcrest-php/hamcrest/Hamcrest/MatcherAssert.php:115
04:44:23 /workspace/src/vendor/hamcrest/hamcrest-php/hamcrest/Hamcrest/MatcherAssert.php:52
04:44:23 /workspace/src/vendor/hamcrest/hamcrest-php/hamcrest/Hamcrest.php:29
04:44:23 /workspace/src/tests/phpunit/HamcrestPHPUnitIntegration.php:31
04:44:23 /workspace/src/extensions/WikibaseLexeme/tests/phpunit/mediawiki/Diff/LexemeDiffVisualizerIntegrationTest.php:177
04:44:23 /workspace/src/tests/phpunit/MediaWikiIntegrationTestCase.php:451
04:44:23 /workspace/src/maintenance/doMaintenance.php:99
04:44:23

and two more similar faulires. Not likely caused by that patch.

Event Timeline

Restricted Application added a project: Wikidata. · View Herald TranscriptAug 27 2019, 5:17 AM
Smalyshev triaged this task as High priority.Aug 27 2019, 5:17 AM
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:06 PM
Krinkle changed the subtype of this task from "Production Error" to "Task".Oct 24 2019, 3:00 PM
Krinkle added a subscriber: Krinkle.

Is this still an issue?

Addshore closed this task as Resolved.Nov 19 2019, 12:42 PM
Addshore claimed this task.
Addshore added a subscriber: Addshore.

Going to close as resolved as I haven't seen anything about this recently.

Restricted Application added a project: User-Addshore. · View Herald TranscriptNov 19 2019, 12:42 PM