Page MenuHomePhabricator

[BUG] Internal error "Invalid option newbies" on Special:NewFiles
Closed, ResolvedPublicBUG REPORT

Description

What is the problem?

Trying to access Special:NewFiles on beta, I see:

MWException from line 148 of /srv/mediawiki/php-master/includes/FormOptions.php: Invalid option newbies

I am assuming that, after T220447 was merged yesterday, this line in NewFilesPager.php needs to be changed.

Steps to reproduce problem

Visit https://commons.wikimedia.beta.wmflabs.org/wiki/Special:NewFiles?start=2018-06-09&end=2018-06-10
or https://en.wikipedia.beta.wmflabs.org/wiki/Special:NewFiles

Environment

Wiki(s): MediaWiki 1.34.0-alpha (8a318ef) 09:46, 28 August 2019

Full stack trace
[XWZUz6wQBHcAAELQc9EAAAAO] /wiki/Special:NewFiles?start=2018-06-09&end=2018-06-10 MWException from line 148 of /srv/mediawiki/php-master/includes/FormOptions.php: Invalid option newbies

Backtrace:

#0 /srv/mediawiki/php-master/includes/FormOptions.php(183): FormOptions->validateName(string, boolean)
#1 /srv/mediawiki/php-master/includes/specials/pagers/NewFilesPager.php(75): FormOptions->getValue(string)
#2 /srv/mediawiki/php-master/includes/pager/IndexPager.php(434): NewFilesPager->getQueryInfo()
#3 /srv/mediawiki/php-master/includes/pager/RangeChronologicalPager.php(105): IndexPager->buildQueryInfo(string, integer, boolean)
#4 /srv/mediawiki/php-master/includes/pager/IndexPager.php(417): RangeChronologicalPager->buildQueryInfo(string, integer, boolean)
#5 /srv/mediawiki/php-master/includes/pager/IndexPager.php(257): IndexPager->reallyDoQuery(string, integer, boolean)
#6 /srv/mediawiki/php-master/includes/pager/IndexPager.php(475): IndexPager->doQuery()
#7 /srv/mediawiki/php-master/includes/specials/SpecialNewimages.php(107): IndexPager->getBody()
#8 /srv/mediawiki/php-master/includes/specialpage/SpecialPage.php(573): SpecialNewFiles->execute(NULL)
#9 /srv/mediawiki/php-master/includes/specialpage/SpecialPageFactory.php(582): SpecialPage->run(NULL)
#10 /srv/mediawiki/php-master/includes/MediaWiki.php(296): MediaWiki\Special\SpecialPageFactory->executePath(Title, RequestContext)
#11 /srv/mediawiki/php-master/includes/MediaWiki.php(892): MediaWiki->performRequest()
#12 /srv/mediawiki/php-master/includes/MediaWiki.php(523): MediaWiki->main()
#13 /srv/mediawiki/php-master/index.php(42): MediaWiki->run()
#14 /srv/mediawiki/w/index.php(3): include(string)
#15 {main}

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 28 2019, 10:37 AM
Bugreporter triaged this task as Unbreak Now! priority.Aug 28 2019, 11:04 AM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptAug 28 2019, 11:04 AM
Restricted Application added a project: User-DannyS712. · View Herald TranscriptAug 28 2019, 11:07 AM

Change 532978 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/core@master] Remove newbies option from NewFilesPager

https://gerrit.wikimedia.org/r/532978

DannyS712 added a comment.EditedAug 28 2019, 11:15 AM

Failing tests:

04:11:19 Running "banana:exif" (banana) task
04:11:19 >> 6 messages lack documentation.
04:11:19 >> Message "exif-customrendered-2" lacks documentation.
04:11:19 >> Message "exif-customrendered-3" lacks documentation.
04:11:19 >> Message "exif-customrendered-4" lacks documentation.
04:11:19 >> Message "exif-customrendered-6" lacks documentation.
04:11:19 >> Message "exif-customrendered-7" lacks documentation.
04:11:19 >> Message "exif-customrendered-8" lacks documentation.
04:11:19 Warning: Task "banana:exif" failed. Use --force to continue.

Messages were introduced by T231385: Recognize EXIF value for iOS Panorama images, and they do appear to have documentation associated with them. Not sure why the tests are failing, but reverting the change from T231385 is the simplest way to solve the flaky tests and unbreak the new files pager

Change 532979 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/core@master] Revert "Recognize exif values for Apple iOS photo modes"

https://gerrit.wikimedia.org/r/532979

Can someone with +2 take a look at the revert and then the actual patch? Jenkins hasn't run a full test on the actual patch, because of the missing messages, but it should pass - the change is a straightforward removal of the option

Change 532979 abandoned by Bartosz Dziewoński:
Revert "Recognize exif values for Apple iOS photo modes"

Reason:
Fixing the test failure with https://gerrit.wikimedia.org/r/c/mediawiki/core/ /532986 instead. The documentation messages were apparently removed by the translation updater bot.

https://gerrit.wikimedia.org/r/532979

Change 532978 abandoned by Jforrester:
Remove newbies option from NewFilesPager

Reason:
This is now a no-op as the original has been merged.

https://gerrit.wikimedia.org/r/532978

Jdforrester-WMF closed this task as Resolved.Aug 28 2019, 9:03 PM