Page MenuHomePhabricator

Link not accessible on web interface after being marked as dead by bot
Closed, ResolvedPublic

Description

Link not accessible on web interface after being marked as dead by bot

The bot marked https://www2.bombardier.com/Used_Aircraft/en/CRJ_Overview.jsp as a dead link, however it is still alive.

While trying to change the status back to alive on the web interface the error "Missing URL: The URL you typed in could not be found." comes up. This is due to the following:

The link on Wikipedia is https://www2.bombardier.com/Used_Aircraft/en/CRJ_Overview.jsp which redirects to the actual page; www2.bombardier.com/Used_Aircraft/en/CRJ_Overview.jsp

However the web interface automatically adds http:// before the link while using the manage URL function. Since this is not the actual page the error messages comes up. This causes the inability to change the URL status to alive again. Same problem occurs while using https before the link.

Could this also be the cause of why the bot sees the page as dead?

Note: http is also added before the link while trying to use the report false positives function causing it also to give the URL not found message, leading to it being not able to be reported.

Diff of the edit made: https://en.wikipedia.org/w/index.php?title=Bombardier_CRJ100/200&diff=prev&oldid=913326556

Event Timeline

First off there are no such things as URLs without a schema (HTTP/HTTPS/FTP). The https does not redirect anywhere.

As for the actual reason you're not finding it, there appears to be an unreported bug in the parser and it appears to be parsing

https://www2.bombardier.com/Used_Aircraft/en/CRJ_Overview.jsp}}

Try searching for that. If it doesn't working, you can use the URL ID in the meantime which I have looked up for you. The ID is 68755265. If you can't find the URL, just type in this number and it should pull it up.

Redalert2fan added a comment.EditedAug 31 2019, 12:00 PM

Thanks for the explanation

Using the link worked, its back to alive now. Adding a archive is not possible since the links differ but I understand that is due to the parsing bug then.

I found the same problem with https://dehavilland.com/en/dash-8-400 and used the above mentioned to also mark it as alive.

Redalert2fan renamed this task from www2 link without HTTP/HTTPS not accessible on web interface after being marked as dead by bot to Link not accessible on web interface after being marked as dead by bot.Aug 31 2019, 12:07 PM
Redalert2fan updated the task description. (Show Details)
Cyberpower678 closed this task as Resolved.Sep 1 2020, 1:39 PM