Page MenuHomePhabricator

+2 in mediawiki/* for Zoranzoki21
Closed, DeclinedPublic

Description

Hi all,
I am Zoran and you all know me as Zoranzoki21. I'm here to contribute with the rest of volunteers and we all have one idea that knowledge should always be available and free for everyone around the world.

Some may think that my contributions are not significant, and I understand that. But any constructive contribution is always welcome.

As for this request, I submit it so that it could contribute even better, that not a couple of users have to do everything (like @Reedy @Jdforrester-WMF @Krinkle @hashar @Umherirrender and few others). And I don’t want to constantly annoy them with my requests, because they too have their own private lives as we, and I don't want to harass them.

I know the rules of CodeReview strategy, so I do not request this to mark my changes with +2 on Gerrit, than to do it on other users' changes that I'm sure are good. I also noticed frequent problems with Continuous-Integration-Infrastructure when the infrastructure is completely blocked because of very big number of queued tests and according to the procedure in those situations the relevant infrastructure is restarted but then many patches got unsettled so we have to recheck it all. And I want to help with that, not to go to IRC and query @Jdforrester-WMF or @Reedy to recheck patches.


My merged patches on Gerrit: https://gerrit.wikimedia.org/r/#/q/owner:Zoranzoki21+status:merged+project:%22%255Emediawiki.*%22

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 1 2019, 6:16 PM
Krenair added a subscriber: Krenair.Sep 1 2019, 6:33 PM
Krinkle updated the task description. (Show Details)Sep 1 2019, 7:37 PM

many patches got unsettled so we have to recheck it all. And I want to help with that, not to go to IRC and query @Jdforrester-WMF or @Reedy to recheck patches.

This sounds like you are asking to join the CI "trusted" group which allows using the recheck functionality (by adding a "recheck" comment in Gerrit). However, it looks like you are already in that group (CI config).

Krinkle updated the task description. (Show Details)Sep 1 2019, 7:39 PM

many patches got unsettled so we have to recheck it all. And I want to help with that, not to go to IRC and query @Jdforrester-WMF or @Reedy to recheck patches.

This sounds like you are asking to join the CI "trusted" group which allows using the recheck functionality (by adding a "recheck" comment in Gerrit). However, it looks like you are already in that group (CI config).

No, I no ask for it.. I know it already :)

Krinkle updated the task description. (Show Details)Sep 1 2019, 8:40 PM

Status of this? :)

Sorry about the delay. I did not realise before, but for MediaWiki reviewer privileges there is a separate process (see documentation).

In short:

Sorry about the delay. I did not realise before, but for MediaWiki reviewer privileges there is a separate process (see documentation).
In short:

Thank you! I will send email on Wikitech-l now.

Done all requested.

Im sorry, i dont mean to be harsh, but you are very far away from the expected level of familarity with mw code and quite frankly skill, expected of someone with +2 rights

Done all requested.

Note: afaict no email was ever sent to wikitech-l. If you want to continue to persue this request, you will need to do that

Done all requested.

Note: afaict no email was ever sent to wikitech-l. If you want to continue to persue this request, you will need to do that

It was sent before 2 days:

See date and time:

Im sorry, i dont mean to be harsh, but you are very far away from the expected level of familarity with mw code and quite frankly skill, expected of someone with +2 rights

I understand, it is ok from you, I know to you think only good.

There is no such email in the archives (and I have not seen one either): https://lists.wikimedia.org/pipermail/wikitech-l/2019-September/thread.html

There is no such email in the archives (and I have not seen one either): https://lists.wikimedia.org/pipermail/wikitech-l/2019-September/thread.html

I saw it, I will try to send it again.

Zoranzoki21 closed this task as Declined.Sat, Sep 28, 7:20 PM

I don't see support, so I will close this task.

@Zoranzoki21 I'm sorry about the silence. There should have been a reply earlier with a clear decision.

I hope you will stay and help. My recommendation would be to watch others and see how they review. And remember that a +1 can still be a very useful way of helping out. Others can recognise the areas you are familiar with and read your comments which will save them time. For example, you can write about what you have reviewed, confirmed or tested and explain why you think it is good to merge. As you gain more experience in certain areas, others will value this expertise and can gain trust in your input and use it as a signal to skip certain steps themselves as part of their review. This is very valuable. Also look at negative reviews and the reasons they mention. There is usually a hint there about something other reviewers can learn from.

Thanks!