Page MenuHomePhabricator

Author and Author_talk aliases needed on nap.wikisource
Closed, ResolvedPublic

Description

There is an "Autore" namespace (102) on napwikisource along with a corresponding talk namespace (103), but no English aliases ("Author" and "Author_talk") have been defined, leading to confusion on the wiki.

Please create the namespace aliases "Author" for 102 and "Author_talk" for 103 for napwikisource and then run the 'namespaceDupes.php' script afterwards.

(Original post follows.)


There is a problem with the namespaces in the newly created Neapolitan Wikisource (T210752: Create Wikisource Neapolitan). Actually, some names were written in the local language (Neapolitan) instead that in English for the canonical field. This brings some importation errors, and some other general issue.

Examples:

"102": {
     "id": 102,
     "case": "first-letter",
     "subpages": "",
     "canonical": "Autore",
     "*": "Autore"
 },
"103": {
     "id": 103,
     "case": "first-letter",
     "subpages": "",
     "canonical": "Autore chi\u00e0cchiera",
     "*": "Autore chi\u00e0cchiera"
 },

See the full list at: https://nap.wikisource.org/w/api.php?action=query&meta=siteinfo&siprop=namespaces

Steps to Reproduce:

Actual Results:

  • You will not be redirected and see the page deletion message.

Expected Results:

Details

Related Gerrit Patches:

Event Timeline

Ruthven created this task.Sep 3 2019, 1:49 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 3 2019, 1:49 PM
Dcljr added a subscriber: Dcljr.Sep 5 2019, 4:52 AM

The kind of configuration quoted in the description seems to be the standard way of handling the "Author" namespace.

For example:

(See entries under 'wgExtraNamespaces' in InitialiseSettings.php.)

It appears that what you want is a namespace alias for each of those NSs:

'wgNamespaceAliases' => [
…
	'+napwikisource' => [
		'Author' => 102,
		'Author_talk' => 103,
	],
…
],

(See, for example, the knwikisource entry under 'wgNamespaceAliases' in same InitialiseSettings.php file.)

A sysadmin should verify that this is indeed the change that will accomplish what you want. (I am not a sysadmin.)

Ruthven added a comment.EditedSep 5 2019, 9:07 AM

@Dcljr It is possible that I've misidentified the problem (@Alex_brollo Forse tu puoi aggiungere qualcosa in più), but, yes, to obtain this result it seems that we need a namespace alias.

While we're at it, would it be possible to add a new namespace for Wikiprojects? Something like:

"104": {
     "id": 104,
     "case": "first-letter",
     "subpages": "",
     "canonical": "Prugetto",
     "*": "Prugetto"
 },

Thanks.

I'm far from an expert about namespace settings, but I noted too that pages prefixed with "Author:" are attributed to ns0 (wgNamespaceNumber value: 0 instead of 102) and this is surely wrong.
Many Author: pages have been redirected to Autore: namespace into nap.wikisource, but this doesn't seem a good trick.

Dcljr added a comment.Sep 6 2019, 12:49 AM

While we're at it, would it be possible to add a new namespace for Wikiprojects? Something like:

"104": {
     "id": 104,
     "case": "first-letter",
     "subpages": "",
     "canonical": "Prugetto",
     "*": "Prugetto"
 },

This is going to seem very familiar to you [wink]: you should open a separate task to request any new namspaces. (This task is about fixing an existing namespace.)

Be sure to include a name for the corresponding talk/discussion namespace and any aliases you want in the same request. Per m:Requesting wiki configuration changes, you will have to link to evidence of local consensus for the change, so you should work on that first, if it hasn't already been discussed. When creating the Phabricator task, you might want to look at T93870 for a successful example of this kind of request.

By the way, since "Prugetto" seems to mean "Project", you might want to consider a different name, just to avoid potential confusion. The English word "Project" is used as a built-in alias on all Wikimedia wikis for the… well… the so-called "project namespace" -- namely, namespace 4, the one that is called "Wikisource" on the Neapolitan Wikisource. (To illustrate this, you can type "Project:" in the search box [but don't hit Enter or click on the magnifying glass icon] and a drop-down menu will appear listing titles starting with "Wikisource:".)

Maybe "Wikiprugetto" (or something like that) might be a better choice?

@Dcljr Thanks, but never mind: I never liked too much the bureaucracy, and we're doing fine with the virtual namespace Wikisource:Prugetto ; see: https://nap.wikisource.org/wiki/Wikisource:Prugetto:Tecnicismi.

So, just the initial request of namespace redirects holds, unless we've to gather local on-wiki community consensus for the change as well. Cheers! ;)

MJL added a subscriber: MJL.Sep 7 2019, 7:13 PM
MJL moved this task from Backlog to Next-up on the Wikisource board.Sun, Dec 29, 2:40 AM
MJL claimed this task.Sun, Dec 29, 2:51 AM

@Alex_brollo I am independently able to confirm that Author: pages are indeed considered namespace 0. See File:Capture-Author.png.

I'm reviewing this matter now to figure out why and to patch it up.

Dcljr added a comment.EditedSun, Dec 29, 3:59 AM

@MJL: Please see T231880#5467072 above.

There is no "Author" namespace on the wiki, only an "Autore" one (NS102) with corresponding talk (NS103). Pages with the pseudo-namespace prefix "Author:" are therefore "assumed" by the software to be in the main namespace (there is no automatic aliasing of the English equivalents, as with "User", "Template", etc., since "Author" is not a built-in MediaWiki namespace, it's an "extra" one).

The wiki just needs the appropriate NS aliases set up (again, see linked comment).

[Edit: striking this part out] Since there are no legitimate "Author:" or "Author_talk:" pages on the wiki (only the one you created for testing), the script 'namespaceDupes.php' doesn't need to be run to transfer any pages into NS's 102 and 103.

I'm going to go ahead and change the description and tags, since this is not really a bug, it's just a site request.

Dcljr renamed this task from Wrongly attributed canonical namespaces on nap.source to Author and Author_talk aliases needed on nap.wikisource.Sun, Dec 29, 4:10 AM
Dcljr updated the task description. (Show Details)
Dcljr added a comment.Sun, Dec 29, 4:13 AM

Actually, might as well run 'namespaceDupes.php'. It's easier that way.

I don't know how to mark this task as "not a bug". Someone else will have to do that.

MJL added a comment.Sun, Dec 29, 4:15 AM

@Dcljr Oh, well then would this be a patch-welcome then?

Dcljr added a comment.Sun, Dec 29, 4:20 AM

@MJL: I don't know. I don't actually work here. [wink]

AFAIK, the tags I've used should get this the attention is needs.

MJL removed MJL as the assignee of this task.Sun, Dec 29, 4:24 AM

Ah, well then I'll just remove myself then. :/

well then would this be a patch-welcome then?

No, see its description. :)

Urbanecm changed the subtype of this task from "Bug Report" to "Task".Wed, Jan 1, 7:10 PM
Urbanecm added a subscriber: Urbanecm.

Actually, might as well run 'namespaceDupes.php'. It's easier that way.
I don't know how to mark this task as "not a bug". Someone else will have to do that.

{{done}}: Add Action, Change Subtype, Task.

Change 561359 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Set Author and Author_talk aliases for Autore NS at napwikisource

https://gerrit.wikimedia.org/r/561359

Urbanecm claimed this task.Wed, Jan 1, 7:12 PM
Urbanecm triaged this task as Low priority.
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptWed, Jan 1, 7:12 PM
Urbanecm moved this task from Backlog to To deploy on the User-Urbanecm board.Wed, Jan 1, 7:12 PM
Urbanecm moved this task from Backlog to To deploy on the Wikimedia-Site-requests board.

Change 561359 merged by jenkins-bot:
[operations/mediawiki-config@master] Set Author and Author_talk aliases for Autore NS at napwikisource

https://gerrit.wikimedia.org/r/561359

Mentioned in SAL (#wikimedia-operations) [2020-01-06T12:45:53Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: 864a2f8: Set Author and Author_talk aliases for Autore NS at napwikisource (T231880) (duration: 00m 55s)

Mentioned in SAL (#wikimedia-operations) [2020-01-06T12:46:32Z] <Urbanecm> mwscript namespaceDupes.php --wiki=napwikisource --fix (T231880)

Urbanecm closed this task as Resolved.Mon, Jan 6, 12:46 PM
[urbanecm@mwmaint1002 ~]$ mwscript namespaceDupes.php --wiki=napwikisource
0 pages to fix, 0 were resolvable.

pagelinks from=17633 ns=0 dbk=Author:Albert_Einstein -> Autore:Albert_Einstein DRY RUN
pagelinks from=17636 ns=0 dbk=Author:Albert_Einstein -> Autore:Albert_Einstein DRY RUN
pagelinks from=17757 ns=0 dbk=Author:Antonio_Ive -> Autore:Antonio_Ive DRY RUN
pagelinks from=17841 ns=0 dbk=Author:August_Kopisch -> Autore:August_Kopisch DRY RUN
pagelinks from=12260 ns=0 dbk=Author:Menotti_Bianchi -> Autore:Menotti_Bianchi DRY RUN
pagelinks from=17841 ns=0 dbk=Author:Nicola_Maldacea -> Autore:Nicola_Maldacea DRY RUN
pagelinks from=17585 ns=0 dbk=Author:Raffaele_Viviani -> Autore:Raffaele_Viviani DRY RUN
7 links to fix, 7 were resolvable.

Looks good!
[urbanecm@mwmaint1002 ~]$ mwscript namespaceDupes.php --wiki=napwikisource --fix
0 pages to fix, 0 were resolvable.

pagelinks from=17633 ns=0 dbk=Author:Albert_Einstein -> Autore:Albert_Einstein
pagelinks from=17636 ns=0 dbk=Author:Albert_Einstein -> Autore:Albert_Einstein
pagelinks from=17757 ns=0 dbk=Author:Antonio_Ive -> Autore:Antonio_Ive
pagelinks from=17841 ns=0 dbk=Author:August_Kopisch -> Autore:August_Kopisch
pagelinks from=12260 ns=0 dbk=Author:Menotti_Bianchi -> Autore:Menotti_Bianchi
pagelinks from=17841 ns=0 dbk=Author:Nicola_Maldacea -> Autore:Nicola_Maldacea
pagelinks from=17585 ns=0 dbk=Author:Raffaele_Viviani -> Autore:Raffaele_Viviani
7 links to fix, 7 were resolvable.

Looks good!
[urbanecm@mwmaint1002 ~]$ mwscript namespaceDupes.php --wiki=napwikisource
0 pages to fix, 0 were resolvable.

0 links to fix, 0 were resolvable.

Looks good!
[urbanecm@mwmaint1002 ~]$
Dcljr added a comment.Tue, Jan 7, 1:14 AM

@Ruthven: Things should now be working as you expected.

Thanks a lot @Dcljr !

@Sannita should be interested as well by this patch, as he's following the ns Autore on nap.source.
Cheers!