Page MenuHomePhabricator

Cannot create new abuse filters
Closed, ResolvedPublic

Description

To reproduce: https://deployment.wikimedia.beta.wmflabs.org/wiki/Special:AbuseFilter/new

'new' has to be taken into account when validating.

Details

Related Gerrit Patches:
mediawiki/extensions/AbuseFilter : wmf/1.34.0-wmf.21Fix filter validation in ViewEdit
mediawiki/extensions/AbuseFilter : masterFix filter validation in ViewEdit

Related Objects

StatusSubtypeAssignedTask
ResolvedRelease hashar
ResolvedDaimona

Event Timeline

Daimona created this task.Sep 4 2019, 12:05 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 4 2019, 12:05 PM

Change 534428 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@master] Fix filter validation in ViewEdit

https://gerrit.wikimedia.org/r/534428

Daimona triaged this task as Unbreak Now! priority.Sep 4 2019, 12:06 PM

Easy fix, marking as train blocker.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptSep 4 2019, 12:06 PM

Change 534429 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@wmf/1.34.0-wmf.21] Fix filter validation in ViewEdit

https://gerrit.wikimedia.org/r/534429

Huji added a subscriber: Huji.Sep 4 2019, 1:15 PM

@Daimona here is where I have a problem with this: we have unit tests that create filters. How come none of them failed with I6436c7d2df8c1f0fc971f4a4079dac9118aa8209 ?

@Daimona here is where I have a problem with this: we have unit tests that create filters. How come none of them failed with I6436c7d2df8c1f0fc971f4a4079dac9118aa8209 ?

Because none of them checks the UI... We'd have better luck with selenium for that, at least to ensure basic things work, like creating a new filter, or editing an existing one, or viewing Special:AbuseFilter without fatals.

I had sent https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/AbuseFilter/+/476519/ for that.

Change 534428 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@master] Fix filter validation in ViewEdit

https://gerrit.wikimedia.org/r/534428

Change 534429 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@wmf/1.34.0-wmf.21] Fix filter validation in ViewEdit

https://gerrit.wikimedia.org/r/534429

Mentioned in SAL (#wikimedia-operations) [2019-09-04T16:38:46Z] <lucaswerkmeister-wmde@deploy1001> Synchronized php-1.34.0-wmf.21/extensions/AbuseFilter: SWAT: [[gerrit:534429|Fix filter validation in ViewEdit (T231985)]] (duration: 00m 58s)

Daimona closed this task as Resolved.Sep 4 2019, 5:02 PM
Daimona removed a project: Patch-For-Review.

Thank you for the quick resolution!