Page MenuHomePhabricator

[Bug] Tapping link with fragment scrolls to wrong area in article on iOS 13
Closed, ResolvedPublicBUG REPORT

Description

How many times were you able to reproduce it?

Observed on iOS 11, 12 and 13 - but occurs perhaps less frequently on iOS 11.

Most consistently manifests on iPad Mini 4 running iOS 13.

Steps to reproduce

  1. Load testwik > bird
  2. Tap the Geography section link

Expected results

Loads the article scrolled to the Geography section

Actual results

Scrolls to middle of the first section

Screenshots (tap image below for animation)

Environments observed

App version:
6.4
OS versions:
All (various frequency)
Device model:
Seen on various iPad models, but most consistently on iPad Mini 4
Device language:
All?

Affected articles?

See repro steps

Event Timeline

Mhurd created this task.Wed, Sep 4, 6:21 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptWed, Sep 4, 6:21 PM
JMinor triaged this task as Low priority.Thu, Sep 5, 8:07 PM

@cmadeo @JMinor any opposition to losing the animation on scroll to section on iPad? There's a simpler, more reliable way to scroll to the right offset but it doesn't animate. Can roll a build if you'd like to test.

cmadeo added a comment.Mon, Sep 9, 3:07 PM

@JoeWalsh, it'd be great to be able to test this!

@cmadeo build 1665 has this change if you'd like to check it out

cmadeo added a comment.Mon, Sep 9, 3:19 PM

Awesome, I forgot my iPad at home (sorry!) but will test when I get back tonight

JoeWalsh renamed this task from [Bug] Tapping link with fragment scrolls to wrong area in article on iPad to [Bug] Tapping link with fragment scrolls to wrong area in article on iOS 13.Mon, Sep 9, 6:37 PM

@cmadeo @JMinor nevermind, it looks like there is a low impact fix for this that preserves animation. Will roll that into the next build (1671) and confirm it fixes the underlying issue on all devices.

Oh! Awesome news, @JoeWalsh!

ABorbaWMF added a subscriber: ABorbaWMF.

Looks fixed on 6.4.0 (1672)

JMinor closed this task as Resolved.Wed, Sep 18, 5:51 PM