Page MenuHomePhabricator

Release MW 1.34
Closed, ResolvedPublic

Description

NOTE: This is a task for the mechanics of doing the release. Please do not add tasks that you believe should block the release to this task. Instead, please add them to the MW-1.34-release project. By definition, tasks in that project are blockers to the release.

This was due to be released in November 2019.

Details

Due Date
Nov 29 2019, 12:00 AM

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 4 2019, 6:41 PM
Jdforrester-WMF changed the subtype of this task from "Task" to "Release".Sep 4 2019, 6:41 PM
Restricted Application changed the subtype of this task from "Release" to "Task". · View Herald TranscriptSep 4 2019, 6:41 PM
Reedy updated the task description. (Show Details)Sep 21 2019, 10:12 PM
Reedy set Due Date to Nov 29 2019, 12:00 AM.Nov 5 2019, 9:33 PM
From task description:

This is a task for the mechanics of doing the release. […] tasks that you believe should block the release […] add them to the MW-1.34-release project [instead].

Reedy triaged this task as High priority.Dec 1 2019, 6:06 PM

Ok!

This is due to be released November 2019.

So that has passed. Not helped with US holidays at the end of the month etc. We really want to get this out before Christmas, so in the next two weeks

T231866: Circular dependency when creating service! ContentLanguage is the main blocker outstanding. I have tagged T239213: Conflicting timestamp in file history as a "regression" in 1.34, but I don't know if it really needs to block the release. I'm certainly not set on it, and can be untagged (but definitely a fix wants back porting if/when one becomes available)

Paladox added a subscriber: Paladox.Dec 1 2019, 8:28 PM
Reedy updated the task description. (Show Details)Dec 3 2019, 2:44 AM
Reedy closed subtask Restricted Task as Resolved.Dec 19 2019, 2:15 PM
Reedy closed this task as Resolved.Dec 19 2019, 2:19 PM
Reedy claimed this task.