Page MenuHomePhabricator

Unexpected line breaks in MediaWiki pages in Chrome 76 (does not happen in Chrome 75)
Closed, InvalidPublic

Description

When viewing the Wikipedia article Medical cannabis in Chrome on a desktop, there is a large gap (at least 10 lines of empty space) inserted shortly after the beginning of the "Society and culture" section. The gap splits up the phrase "Czech Republic", and there is also an unnecessary line break after "Countries that have legalized the medical use of cannabis include". When I zoom out far enough, however, the issue disappears. Also, I don't see the problem when viewing the page in Firefox or Microsoft Edge. I did verify that this issue is not isolated to my computer by viewing the page in Chrome on a different computer and observing the exact same problem.

This is all very strange because I viewed the article one day earlier (night of September 3) and there was no problem. I am using the 76.0.3809.132 version of Chrome on a Dell desktop computer (Windows 10). Since that version of Chrome has been released for over a week, and since it appears that the problem started occurring on September 4, I would guess some kind of change was made to Wikipedia on September 4 that is causing the problem. Thank you for giving this issue your attention.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 5 2019, 5:23 AM
Jamesy0627144 updated the task description. (Show Details)Sep 5 2019, 5:42 AM
Aklapper closed this task as Invalid.Sep 5 2019, 9:40 AM

Hi @Jamesy0627144, thanks for taking the time to report this and welcome to Wikimedia Phabricator!

I have tried with several canvas widths in Chromium 75 (via Ctrl+I) and I cannot reproduce on https://en.wikipedia.org/w/index.php?title=Medical_cannabis&oldid=912920783#Legal_status :

Similar to T230623#5457595 (though that is a different problem), please file a bug report to the Chromium developers as it looks like this is a bug in their browser: https://bugs.chromium.org/p/chromium/issues/entry and https://bugs.chromium.org/p/chromium/issues/list - thanks.

Closing this task as invalid as I do not think that there is somehing to fix in code maintained by Wikimedia, but in code maintained by the Chrome / Chromium maintainers.

Aklapper renamed this task from Unwanted line breaks when viewing Wikipedia article in Chrome to Unexpected line breaks in MediaWiki pages in Chrome 76 (does not happen in Chrome 75).Sep 6 2019, 12:35 PM

I also tried with Chromium version 76 now and I can now reproduce the problem:

So this really looks like a Chromium problem to me, given that it worked in Chromium 75 yesterday.

Yes, it's a problem with version 76, but the problem goes away in the Beta 77 version that I tried. The person with Chrome that I have been talking to says the Beta version should become the stable version in about a week.

https://bugs.chromium.org/p/chromium/issues/detail?id=1001258