Page MenuHomePhabricator

99+ notifications after enable of showing "ping notifications" on web
Closed, InvalidPublicBUG REPORT

Description

When I enabled notifications in settings on Serbian Wikipedia, related to ping to be showed on web version of Wikipedia, I got this and I can't get rid of this notifications even I click mark as read:

Event Timeline

Restricted Application added a project: Growth-Team. · View Herald TranscriptSep 5 2019, 1:33 PM
Restricted Application added subscribers: Petar.petkovic, Aklapper. · View Herald Transcript
kostajh added a subscriber: kostajh.

@Zoranzoki21, are you saying that you cannot mark any notifications as read? Or one particular one?

This comment was removed by Zoranzoki21.

Ok, I found a solution. I marked as read each group of 50 notifications, it was 343.

So I get rid of these notifications.

But we should found a bug, how I can get notifications which are 2 years old after changing settings related to notifications for ping.

JTannerWMF closed this task as Invalid.Thu, Sep 26, 7:47 PM
JTannerWMF added a subscriber: JTannerWMF.

If you previously enabled a ping notifications then disable them then later enable them then the old ones will come back. This is not a bug, it is working as designed.

With this in mind, do you believe the way it is working is okay or should it be designed differently? @Zoranzoki21