Page MenuHomePhabricator

Issue new SSL Client Certificate for jcuriel
Closed, ResolvedPublic

Description

The SSL client certificate for jcuriel will expire on 20190911. Please work with them to get the new certificate issued and installed.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptThu, Sep 5, 6:35 PM

@JCuriel was provided with the cert and password. He was working on getting it installed in his browser but didn't complete as he had a deadline to meet. I will check back with him early next week.

Confirmed with Jonathan that the cert install worked and he is using the new cert.

DStrine moved this task from Triage to FR-Ops on the Fundraising-Backlog board.Wed, Sep 11, 9:28 PM

Had some issues with this working one day and then not the next. It ends up that Jonathan had imported the cert into the OS keychain but not into firefox also. Firefox requires the cert to be imported specifically. The behavior looked like it was working and then failed because firefox was still using the old certificate until it expired. Additionally, the browser needed to be quit and restarted as it cached the certificate it was using for the connection.

I walked through his config with him and cleared out all old/expired certs and ensured his new cert was working. I'll see if there is anything we can clarify in the documentation so this doesn't trip up other users.

Dwisehaupt closed this task as Resolved.Fri, Sep 13, 6:13 PM
Dwisehaupt triaged this task as Normal priority.Tue, Sep 17, 5:03 PM