Page MenuHomePhabricator

errors when I run "rebuildImages.php" (MW 1.30)
Closed, DeclinedPublicBUG REPORT

Description

Steps to Reproduce:

  • run "rebuildImages.php" on my system

Actual Results:

  • Warning: Missing img_description_text and img_description_data fields in row with MIGRATION_OLD [Called from CommentStore::getCommentInternal in /opt/htdocs/mediawiki/includes/CommentStore.php at line 229] in /opt/htdocs/mediawiki/includes/debug/MWDebug.php on line 309
  • Warning: Missing oi_description_text and oi_description_data fields in row with MIGRATION_OLD ...

Expected Results:

  • no warnings

MW Version

  • 1.30.0 (830bb58) 17:58, 8 December 2017

Event Timeline

Revansx created this task.Sep 5 2019, 8:01 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 5 2019, 8:01 PM
Revansx added a comment.EditedSep 5 2019, 8:02 PM

The script doesn't give me any way to identify which files are producing this warning or how to fix them. Are there any better diagnostics I can run?

Assuming this task is about MediaWiki-Maintenance-scripts hence adding project tag so others can find this task when searching for tasks under that project or looking at that project workboard. Not sure why this was tagged with Core Platform Team.

@Revansx: Please note that MediaWiki 1.30.0 is an old, insecure, unsupported version. Usually I'd directly decline this task and ask if this still happens in supported software. See https://www.mediawiki.org/wiki/Download and https://www.mediawiki.org/wiki/Manual:Upgrading

Anomie closed this task as Declined.Sep 6 2019, 1:55 PM
Anomie added a subscriber: Anomie.

@Revansx: Please note that MediaWiki 1.30.0 is an old, insecure, unsupported version. Usually I'd directly decline this task and ask if this still happens in supported software. See https://www.mediawiki.org/wiki/Download and https://www.mediawiki.org/wiki/Manual:Upgrading

This was likely fixed by rMW3488f495321a: Replace selectFields() methods with getQueryInfo(), which is included in MediaWiki 1.31 and later. On that basis, I'm going to go ahead and make that decline.

Is it true that these issues will likely go away when I upgrade to 1.31?

@Revansx: You can test and find out - see the previous comment which includes the word "likely" (but not "definitely"). :) You should upgrade anyway as 1.30 nowadays is an unsupported insecure version.