Page MenuHomePhabricator

TemplateData
Closed, DeclinedPublic

Description

Hi I have installed TemplateData along with TemplateWizard extension but when I follow the instructions it bugs out when I search for infobox person and if I select any of the available templates in the drop down eg: Infobox

I get this error:

No parameters could be determined for this template due to absence of TemplateData documentation. You may insert the template without parameters.

how can I fix this and connect the relevant data.

Hope you can help.

Kind Regards

D

Event Timeline

Restricted Application added projects: VisualEditor, Community-Tech. · View Herald TranscriptThu, Sep 5, 10:49 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Sorry to hear it's not working smoothly!

Do you have templatedata defined for that template? Are there any errors in it? Is the job queue being processed correctly?

Hi @AlgorithmGG, thanks for taking the time to report this and welcome to Wikimedia Phabricator!

but when I follow the instructions

Can you please link to the instructions and provide steps to reproduce? Which exact MediaWiki version and which TemplateData and TemplateWizard versions is this about? Please see https://www.mediawiki.org/wiki/How_to_report_a_bug - thanks!

Krinkle removed Krinkle as the assignee of this task.Fri, Sep 6, 12:04 AM
Krinkle added a subscriber: Krinkle.
Krinkle removed a subscriber: Krinkle.

Thanks for responding
@Aklapper

To be honest I followed the instructions in the Template wizard found below.
https://www.mediawiki.org/wiki/Help:Extension:TemplateWizard

Looking at the TemplateData instructions its saying to write parameters from scratch or import the relevant documentation.

@Samwilson No I do not.
@Krinkle wants nothing to do with it.

I am hoping there is someone with a solution other than writing my own Templates.

Anyway all the best Guys

Cheers

Which wiki are you using it on, and which template are you trying to insert?

If it's English Wikipedia, then most infoboxes have templatedata defined, but there are lots of other templates that do not. If you want to use one of these, you need to add templatedata. See https://www.mediawiki.org/wiki/Help:TemplateData for how to do that. If you aren't comfortable doing that, you could leave a message on the template's talk page asking someone else to (perhaps pinging one of the authors of the template; check the history for who they are).

Hi @Samwilson I am using the latest stable version I am comfortable doing it. I used the stable version of TemplateData, when that failed I used the master version and still have the same issue there is another version I haven't tried yet. There is something missing! Although it looks like it will allow to write my own parameters I don't have access to the templates even the InfoBox bugs out hence the error message I initially posted.

Aklapper removed a subscriber: Krinkle.Fri, Sep 6, 7:03 AM

Hi @AlgorithmGG, please answer all my questions that I asked in T232168#5470065. Thanks!

@Aklapper
Sorry I missed the question?

@AlgorithmGG:

Which exact MediaWiki version and which TemplateData and TemplateWizard versions is this about?

@Aklapper the stable version of mediawiki 1.33.0
TemplateData version 0.1.2 (7ffe97a) TemplateWizard version 0.1.0 (096f34e) what versions should I be using?

Cheers

@AlgorithmGG TemplateWizard requires having TemplateData definition in each template.

If you're importing the templates from another wiki, they should already have it, but if they don't, you can copy them over. Otherwise, TemplateData has a helpful dialog that helps you add the definition of the fields, which includes an import functionality that can make this process easier.

TemplateWizard won't be able to help you add templates if they don't have TemplateData definition in them, because it won't be able to tell which field does what action.

Many thanks @Mooeypoo I'll have a look at this cheers.

@Mooeypoo where can find templatedata to import please? I don't want to mirror another wiki, just looking for nice styiing someting neat. Cheers

If you have TemplateData installed, you can add $wgTemplateDataUseGUI = true; to your LocalSettings.php and you'll see a "Manage TemplateData" button when you edit a template.

@Mooeypoo thanks. the manage template button is already active. Is there anyway to have it working as described in the TemplateWizard instructions?

AlgorithmGG added a comment.EditedSat, Sep 7, 9:21 PM

All I get is script error: no such module when a template is inserted @Mooeypoo

TemplateWizard allows you to insert templates into a page if they have TemplateData definition.
TemplateData extension can help you set definitions in your templates.

If you have module errors or javascript errors while trying to load either one of those, I'll need to see the entire error message with more details about when it happens to be able to try and help.

@Mooeypoo thanks. the manage template button is already active. Is there anyway to have it working as described in the TemplateWizard instructions?

Can you say which instructions you're talking about?

This comment was removed by Ladsgroup.

I'm sorry to hear that. If you ever change your mind, we'll be happy to try and help guide you through the process.
In any case, this page might be able to help as well, if you need it: https://www.mediawiki.org/wiki/Help:TemplateData

JTannerWMF added a subscriber: JTannerWMF.

There doesn't appear to be an action for the Editing-team at this time

Aklapper closed this task as Declined.Wed, Sep 11, 4:40 PM

I'm closing this task as per the task author's last comment. As already pointed out, healthy and constructive criticism is welcome in the future.

Thanks by the way. Cheers