Page MenuHomePhabricator

WWT: Support Hidden Contributor Names
Closed, ResolvedPublicBUG REPORT

Description

What is the problem?

There are circumstances under which a contributor's username is hidden.

Currently, the revision details popup shows nothing for the username and the User_talk and Special:Contributions links are invalid. See screenshot.

I don't think we are likely to see this problem often. It would require a contributor's username to be hidden but not have their revision reverted. Unless a user explicitly goes to the old revision (like the example in the reproduction steps).

Acceptance Criteria:

  • If there is a hidden contributor, display the following: "(Username or IP removed)"
  • No talk page or contribs link needed
Steps to reproduce problem
  1. https://en.wikipedia.org/w/index.php?title=Cadeyrn_Neville&oldid=597866123
  2. Turn on WWT
  3. Click any word in the second sentence
Screenshots (if applicable):

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 6 2019, 1:45 PM

Nice catch! I recommend doing what MediaWiki does and replace "Foobar (talk | contribs)" with "(Username or IP removed)", as you see in the pink bar at the top of https://en.wikipedia.org/w/index.php?title=Cadeyrn_Neville&oldid=597866123

ifried added a subscriber: ifried.Sep 10 2019, 8:52 PM

@dom_walden @MusikAnimal When/why would a contributor's username be hidden? I'm unfamiliar with this behavior and would like to learn more. Thanks!

MusikAnimal added a comment.EditedSep 10 2019, 9:01 PM

When/why would a contributor's username be hidden? I'm unfamiliar with this behavior and would like to learn more. Thanks!

Revision deletion (which on English Wikipedia could be a result of revision deletion by an admin or "suppression" by oversighters). This is done say because someone had a very offensive username, or someone accidentally edited while logged out and asked their IP to be removed from public view.

In our case, we simply check if a username was given, and if not we know we should show "(Username or IP removed)". The revision ID should still be present, however, so we have a diff to link to.

dom_walden updated the task description. (Show Details)Sep 16 2019, 3:43 PM
ifried updated the task description. (Show Details)Sep 17 2019, 11:30 PM
ifried renamed this task from Work out what we want to do with hidden contributor names to Work out what we want to do with hidden contributor names [small].Sep 17 2019, 11:34 PM
ifried moved this task from To Be Estimated/Discussed to Estimated on the Community-Tech board.
ifried renamed this task from Work out what we want to do with hidden contributor names [small] to WWT: Support Hidden Contributor Names.Sep 19 2019, 12:15 AM
ifried moved this task from Estimated to Kanban (Q1 2019-20) on the Community-Tech board.
Mooeypoo added a subscriber: Mooeypoo.

This is merged to master. I will update the self-hosted gadget in the next few days before it moves to product (if all is well :) .

For hidden contributors, the revision details popup now looks like:

@ifried I didn't notice this before, but the text of hidden contributors is not highlighted when you hover over it.

Fixing this might be further complicated if we consider the case of a revision with more than one hidden contributor. By design, MediaWiki will not give us personally identifiable information about a hidden user. Therefore, WWT would not be able to distinguish one hidden user from another. If we are to highlight the text of hidden contributors, we would have to highlight it all, even if it is from different contributors.

I also don't know if this means the attribution percentage of all hidden contributors will be added together. I don't have an example to check this.

I am not sure what we should do. I have not looked at how common a situation this will be.

This is working as expected (I also tested it), so I'm marking this work as Done.

@dom_walden Thanks for pointing out that the hover effect doesn't apply to hidden contributors. I'm not sure if we need to fix or change this, but it's something to keep in mind (especially when we begin collecting user feedback after the official beta release). We can leave the behavior as is for now, and we can explore later, if need be.

ifried closed this task as Resolved.Oct 31 2019, 9:37 PM
ifried moved this task from Product sign-off to Done on the Community-Tech (Kanban-Q2-2019-20) board.