Page MenuHomePhabricator

Footnotes overflow in infoboxes
Closed, InvalidPublic

Description

Footnote links overflow infobox border in latest Chrome. Seems its cause by css style unicode-bidi: isolate; on sup.reference. Can wee add display: inline-block; on sup.reference to solve this problem?

Examples:
https://ru.wikipedia.org/wiki/Спинрад,_Норман
https://ru.wikipedia.org/wiki/Хингис,_Мартина
https://ru.wikipedia.org/wiki/Сугияма,_Ай

Actual behavior: words not wrapping.

Expected behavior: words wrapping.

Event Timeline

SerDIDG created this task.Sep 9 2019, 2:24 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 9 2019, 2:24 AM
Izno closed this task as Invalid.Sep 9 2019, 3:24 AM
Izno added a subscriber: Izno.

Module:Infocards sets class=nowrap on that element, which has whitespace: nowrap from common.css. The elements are not wrapping accordingly.

Maybe you shouldn't do that, or change what is nowrapped? :)

SerDIDG added a comment.EditedSep 9 2019, 3:39 AM

@Izno, please check one more time, where nowrap class is implemented: <nowrap>date</nowrap><footnotes> <nowrap>age</nowrap>. Normal space character separates these two pieces and should wrap. Even if there was nowrap on the entire container, then the infobox would be stretched wide, not overflow.

Izno reopened this task as Open.Sep 9 2019, 3:54 AM

@Izno, please check one more time, where nowrap class is implemented: <nowrap>date</nowrap><footnotes> <nowrap>age</nowrap>. Normal space character separates these two pieces and should wrap.

Oh I'm sorry, I read the module wrong entirely.

Ghuron added a subscriber: Ghuron.Sep 9 2019, 7:05 AM
TheDJ added a subscriber: TheDJ.Sep 9 2019, 9:48 AM

works fine for me with Chrome 77.0.3865.70 (Official Build) beta (64-bit) MacOS. What exact version do you have @SerDIDG ?

Ghuron added a comment.Sep 9 2019, 9:52 AM

Can reproduce all three links above on Chrome 76.0.3809.136 (Official Build) (64-bit) ChromeOS

SerDIDG added a comment.EditedSep 9 2019, 11:32 AM

Reproduced on 76.0.3809.132 (64-bit) Win 10, but not on the same version for macOS. New IE has arrived.

Izno moved this task from Unsorted backlog to Defect backlog on the Cite board.Oct 12 2019, 12:18 PM
TheDJ added a comment.Oct 12 2019, 2:46 PM

Upstream states: "I can't reproduce. Could you try Canary?" and was then merged into https://bugs.chromium.org/p/chromium/issues/detail?id=1002442 and marked as fixed.

Seems like not reproduced on 77.0.3865.120 (Official Build) (64-bit).

Aklapper closed this task as Invalid.Oct 13 2019, 8:49 AM
Aklapper added a project: Upstream.

Thanks for retesting! I'm [closing this as invalid](https://www.mediawiki.org/wiki/Bug_management/Bug_report_life_cycle) as the fix for this had to happen outside of code maintained by Wikimedia.