Page MenuHomePhabricator

Language-tagged template transformation stops too early on labeled "pipe" wikilinks
Closed, ResolvedPublic3 Estimated Story PointsBUG REPORT

Description

We received a bug report saying that the language-tagged text on an import was broken. The final import text seems to have been manually corrected, see here:
https://commons.wikimedia.org/wiki/Special:Diff/364855386

Steps to reproduce/demo:

Bug
|Description = {{en|Test description with a [[:test2wiki:w:en:Link}}|link]] to the English Wikipedia.
Fixed
|Description = {{en|Test description with a [[:test2wiki:w:en:Link|link]] to the English Wikipedia.}}

The relevant rule being used is one with an @ sign here: https://commons.wikimedia.beta.wmflabs.org/wiki/Extension:FileImporter/Data/en.wikipedia#Transfer

Event Timeline

awight created this task.Sep 9 2019, 8:51 AM
Restricted Application added a project: archived--TCB-Team. · View Herald TranscriptSep 9 2019, 8:51 AM
awight changed the subtype of this task from "Task" to "Bug Report".Sep 10 2019, 10:01 PM

Change 538166 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/extensions/FileImporter@master] [WIP] Fix WikitextContentCleaner failing on [[labeled|links]]

https://gerrit.wikimedia.org/r/538166

thiemowmde added a subscriber: thiemowmde.

This is indeed a bug, caused by my incomplete attempt to parse wikitext. https://gerrit.wikimedia.org/r/538166 demonstrates the issue with a currently failing test. I would like to teach our parser to skip pairs of [[…]] possibly including pipes. This is just not a one-liner and will take a little while, possibly worth 3 story points.

thiemowmde moved this task from Incoming to In QWERTY sprint on the archived--TCB-Team board.
thiemowmde set the point value for this task to 3.
thiemowmde moved this task from Sprint Backlog to Review on the WMDE-QWERTY-Sprint-2019-09-10 board.
thiemowmde added a subscriber: JStrodt_WMDE.

Change 538166 merged by jenkins-bot:
[mediawiki/extensions/FileImporter@master] Fix WikitextContentCleaner failing on [[labeled|links]]

https://gerrit.wikimedia.org/r/538166

thiemowmde updated the task description. (Show Details)Sep 27 2019, 9:50 AM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptSep 27 2019, 9:50 AM
thiemowmde renamed this task from Language-tagged template transformation may be causing problems to Language-tagged template transformation stops to early on labeled "pipe" wikilinks.Sep 27 2019, 9:52 AM
awight renamed this task from Language-tagged template transformation stops to early on labeled "pipe" wikilinks to Language-tagged template transformation stops too early on labeled "pipe" wikilinks.Oct 1 2019, 8:47 AM
thiemowmde closed this task as Resolved.Oct 9 2019, 2:14 PM