Page MenuHomePhabricator

Newcomer tasks: welcome survey changes
Closed, ResolvedPublic

Description

The newcomer tasks experience will be somewhat personalized based on welcome survey responses. This is an opportunity to modify the welcome survey options to fit the personalization the feature will do. We have also decided to ask one of the welcome survey questions directly on the homepage instead, so that question will be removed from the survey.

Mockup: https://wikimedia.invisionapp.com/share/FUTVMSLV24X#/screens/383472072

These are the changes required for the first version of newcomer tasks:

Question 1 (the “task” question)

  • Remove the following options:
    • “To add information to a Wikipedia article”
  • Add the following options:
    • “To add or change information in a Wikipedia article”
    • “To add a photo or image to a Wikipedia article”
    • “I’m participating in a program, class, or event”
  • These new and changed response options should be new values for the purposes of storage -- they should not be overwritten to any existing values. This will help facilitate clear analysis.

Question 3 (the “topic” question)

  • Remove this question from the welcome survey entirely. We will ask this information on the homepage instead.

Other copy changes

  • Subtitle
    • This is the current subtitle on the survey: "Help us make Wikipedia better for our new users like you by answering a few optional questions."
    • Should be changed to: "Help us improve your Wikipedia experience by answering a few optional questions."
  • "Thank you" screen
    • This is the current line: "Your answers will be used to help us try to make Wikipedia better for all new users."
    • Should be changed to: "Your answers will help us give you useful ways to get started on Wikipedia."

Event Timeline

This is ready for development.

@nettrom_WMF -- do you know of any reason not to just make this change whenever we're ready with it? Is it potentially disruptive to any analysis that's in flight?

@MMiller_WMF : I don't see this interfere with anything that's currently going on, no. We don't have any experiments relying on those answers, and we've got about a couple of months of data from Arabic at this point, which should provide us with stability in responses there. Feel free to have an engineer pick it up.

@MMiller_WMF : I just noticed T211446 is still open. How do these two tasks relate to each other, is T211446 a blocker for this one?

@nettrom_WMF -- god question. T211446 is a task that has captured some ideas for changes to the welcome survey that we've had over time, and this task here (T232400) accomplishes one of them. I'll now modify T211446 to show that that idea is covered by this task.

MMiller_WMF updated the task description. (Show Details)Sep 13 2019, 8:46 PM

Change 536691 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] WelcomeSurvey: Add/change answer options for "reason" question

https://gerrit.wikimedia.org/r/536691

Change 536700 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] WelcomeSurvey: Remove "topics" question

https://gerrit.wikimedia.org/r/536700

Change 536705 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] WelcomeSurvey: Remove multiselect infusion code

https://gerrit.wikimedia.org/r/536705

I received a good note from @ppelberg today -- when we first wrote the welcome survey, we weren't using it to personalize the new user's experience. So the survey doesn't say in any of its language that it will be beneficial to the user taking it. Now that we will be personalizing their experience, we can use clearer language to them so that they understanding.

Therefore, I would like us to make these additional copy changes to the welcome survey:

  • Subtitle
    • This is the current subtitle on the survey: "Help us make Wikipedia better for our new users like you by answering a few optional questions."
    • Should be changed to: "Help us improve your Wikipedia experience by answering a few optional questions."
  • "Thank you" screen
    • This is the current line: "Your answers will be used to help us try to make Wikipedia better for all new users."
    • Should be changed to: "Your answers will help us give you useful ways to get started on Wikipedia."

I'll also add these changes to the task description. Let me know if I should make a separate task.

MMiller_WMF updated the task description. (Show Details)Mon, Sep 16, 9:05 PM

@MMiller_WMF : while I'm unsure how many users actually read these, I'm wondering if we're sure that this won't affect their motivation to respond? Partly because it's not clear how we're using these answers to improve their experience. And secondly, we might be benefiting from a generally positive view of Wikipedia when it comes to willingness to respond.

@nettrom_WMF -- I think it is possible that these lines affect a user's motivation, but I don't know whether it will decrease or increase it. On the one hand, it sounds like a less altruistic motivation (to help yourself instead of others), but on the other hand it sounds like there's more in it for you. Given that I'm not sure which way it would go, I think it's better to try to make these statements cleave as closely as possible to the reality of how we're using the responses.

But are you saying that the lines as I wrote them give some information, but not enough, about how the responses will be used, and being in that limbo zone could be a turn-off? If so, how do you recommend we approach it?

Change 536691 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] WelcomeSurvey: Add/change answer options for "reason" question

https://gerrit.wikimedia.org/r/536691

Change 536700 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] WelcomeSurvey: Remove "topics" question

https://gerrit.wikimedia.org/r/536700

Everything is ready for QA except "Other copy changes", which is pending resolution of T232400#5497642

Change 536705 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] WelcomeSurvey: Remove multiselect infusion code

https://gerrit.wikimedia.org/r/536705

Etonkovidova added a comment.EditedWed, Sep 18, 9:33 PM

@MMiller_WMF - all looks good, except, as @kostajh pointed out in the comment above, does the following needs some additional deliberation (currently it's not implemented)?

Other copy changes
Subtitle

    This is the current subtitle on the survey: "Help us make Wikipedia better for our new users like you by answering a few optional questions."
    Should be changed to: "Help us improve your Wikipedia experience by answering a few optional questions."
"Thank you" screen
    This is the current line: "Your answers will be used to help us try to make Wikipedia better for all new users."
    Should be changed to: "Your answers will help us give you useful ways to get started on Wikipedia."

Just for the record - the new look of Special: WelcomeSurvey page:

@nettrom_WMF -- I think it is possible that these lines affect a user's motivation, but I don't know whether it will decrease or increase it. On the one hand, it sounds like a less altruistic motivation (to help yourself instead of others), but on the other hand it sounds like there's more in it for you. Given that I'm not sure which way it would go, I think it's better to try to make these statements cleave as closely as possible to the reality of how we're using the responses.
But are you saying that the lines as I wrote them give some information, but not enough, about how the responses will be used, and being in that limbo zone could be a turn-off? If so, how do you recommend we approach it?

Coming back to this again, I think my main concern is that the change from altruistic to self could negatively affect motivation to respond, but we can put it in production and check response rates. As for the wording about how we use the information, I can't think of a better way to phrase it, so let's go with what we have.

Thanks, @nettrom_WMF.

@kostajh -- we are good to proceed with the wording changes as written in the task description.

Change 538833 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] WelcomeSurvey: Copy updates to subtitle and confirmation text

https://gerrit.wikimedia.org/r/538833

Change 538833 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] WelcomeSurvey: Copy updates to subtitle and confirmation text

https://gerrit.wikimedia.org/r/538833

The text changes are in place. For @MMiller_WMF review.

(1) On betalabs I see a shortened version of 'Thank you' page

vs 'Thank you' page that is present on testwiki - is it intentional?

(2) Some observations:

  • the only redirect option on 'Thank you' page is to Homepage, disregarding from which context a user created an account?
  • 'Please select' is displayed twice (which makes sense on mobile)

@Etonkovidova -- the shortened version of the Thank you page is supposed to be there for users in the homepage treatment group. They are not supposed to get all that text and links to get started, because they are supposed to go to their homepage to see that stuff. The long version is for users in the homepage control group. Maybe your betalabs user is in a treatment group and your testwiki user is in a control group? Please check that.

After creating their account, a user in the homepage treatment group is supposed to have two buttons: one for the homepage and one for their original context (unless their original context was Main page). A user in the control group is supposed to have one button: to go to their original context. If that's not what you're seeing, that's a bug.

@RHo can speak to whether the "Please select..." is supposed to appear twice.

RHo added a comment.Sat, Sep 28, 9:03 PM

@RHo can speak to whether the "Please select..." is supposed to appear twice.

hi @@Etonkovidova - Do you mean it appears twice in the options? That would be wrnog. However in the screenshot attached it seems like it the first "Please select..." is the default selected option in the dropdown, and the second is the option, in which case that is fine.

@RHo can speak to whether the "Please select..." is supposed to appear twice.

hi @@Etonkovidova - Do you mean it appears twice in the options? That would be wrnog. However in the screenshot attached it seems like it the first "Please select..." is the default selected option in the dropdown, and the second is the option, in which case that is fine.

Yes, makes sense (that's why I put it as "observations"). - I saw one as a prompt and another one is an option phrased the same as a prompt which is not the case . A user is able to submit an empty Welcome form ("Finish" button is always active, but I suppose it's as intended)

I tried to look up some best practices on how those drop-down menus should deal with suggestions - "please select", e.g. should it go away from the main textbox when I open the drop-down - and I could not find anything definite. So, let's leave it.

@Etonkovidova -- the shortened version of the Thank you page is supposed to be there for users in the homepage treatment group. They are not supposed to get all that text and links to get started, because they are supposed to go to their homepage to see that stuff. The long version is for users in the homepage control group. Maybe your betalabs user is in a treatment group and your testwiki user is in a control group? Please check that.
After creating their account, a user in the homepage treatment group is supposed to have two buttons: one for the homepage and one for their original context (unless their original context was Main page). A user in the control group is supposed to have one button: to go to their original context. If that's not what you're seeing, that's a bug.

Ok, I checked for users the case for the control group user (users who don't get 'growthexperiments-homepage-enable' = 1). All works as expected,
The case for two buttons for the treatment group (an account created when a user views a page), it seems that it cannot be tested in betalabs where all users are in the treatment group.
@MMiller_WMF - I've added the case above to my post-deployment checklist. Since the implementation is complete, you may close it.

MMiller_WMF closed this task as Resolved.Tue, Oct 1, 12:26 AM

Thank you!