Page MenuHomePhabricator

Math markup rendering with insufficient contrast in articles
Closed, InvalidPublic

Description

OTRS Ticket#2019090810005009 is a report that math characters are not displaying properly in Firefox 67.0.4 on Linux. The math text is too light to read.

Example:
https://en.wikipedia.org/wiki/Feynman_diagram#Canonical_quantization_formulation

Another screenshot in the OTRS ticket shows that the reporter is receiving the fallback SVG and is not directly rendering the MathML. In any case, their browser renders the Mozilla MathML Torture Test correctly. Opening the SVG in a new tab results in the correct colors.

The issue persisted with Firefox in safe mode (addons disabled). They mentioned that the issue appears when a dark desktop theme is selected and the browser uses system colors.

The reporter was not able to replicate the issue in Google Chrome 76.0.3806.132. I was not able to reproduce the issue in Firefox 69.0 on Linux.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 10 2019, 2:28 AM

Thanks for the bug report with good information already. :)

Which "dark desktop theme" is this about, on which distribution and which distribution version, with which desktop environment? Sounds like a bug either in the theme, or the theming machine, or in the Firefox package shipped by that distribution.

Cannot reproduce either in https://en.wikipedia.org/wiki/Feynman_diagram#Canonical_quantization_formulation and "MathML with SVG or PNG fallback (recommended for modern browsers and accessibility tools)" chosen at https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-rendering in Firefox 69 on Fedora Linux.

OS - (uname output) Linux 4.19.67_p2-debian-sources-lts x86_64
DE - XFCE 4.12
Theme - Vertex-Dark (https://github.com/horst3180/vertex-theme)

Aklapper closed this task as Invalid.Sep 10 2019, 4:33 PM

Looking at stuff like https://github.com/horst3180/Vertex-theme/issues or https://github.com/horst3180/vertex-theme/issues/256 I'm boldly closing this task as invalid here.

Please reopen if that problem still happens when not using "Vertex-Dark" but the default theme in Firefox.

AntiCompositeNumber added a comment.EditedSep 10 2019, 9:56 PM

@Aklapper They report that other dark DE themes (Adawaita-Dark and Equilux) still have the issue. Light and default themes do not.

Cannot reproduce in Firefox 69 on Fedora after setting the application theme to Adwaita-Dark in GNOME's Tweaks application: