Page MenuHomePhabricator

Newcomer tasks: homepage changes based on initiation (mobile)
Closed, ResolvedPublic

Description

When the user initiates the suggested edits module, as described in T232419, the homepage modules change to make room for the suggested edits module. The start module also changes because a newcomer completed initiating the suggested edits module.

This task is about how the start module changes on mobile. Desktop is ticketed in T232420.

A separate task exists for the mobile preview card that appears on the mobile homepage after initiation: T235810

Specifically:

  • Once the user initiates the suggested edits module and completes the overlays, the submodule about suggested edits should remain in the start module. It should not disappear like on desktop.
  • The submodule should remain there with its icon becoming a green checkmark, just like the other modules in their completed state. Mockup here.
  • The submodule should also remain in the start module preview card on the homepage, but its header should change from "Start editing" to "See suggested edits".
  • The suggested edits module preview should appear immediately below the start module. Ticketed in T235810.

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : masterDo not show StartEditing dialog when suggested edits are already active
mediawiki/extensions/GrowthExperiments : masterNewcomer tasks: do not hide completed StartEditing module on mobile
mediawiki/extensions/GrowthExperiments : masterSuggested edits: Load suggested edits after activation

Event Timeline

Moving to Needs Design and assigning to @RHo.

RHo updated the task description. (Show Details)Oct 14 2019, 3:27 PM
RHo removed a project: Growth Design.
MMiller_WMF removed RHo as the assignee of this task.Oct 18 2019, 1:38 AM
MMiller_WMF added a project: Design.
MMiller_WMF updated the task description. (Show Details)

This task is now up-to-date and ready for development.

MMiller_WMF updated the task description. (Show Details)Oct 18 2019, 1:39 AM

Change 548742 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Suggested edits: Load suggested edits after activation

https://gerrit.wikimedia.org/r/548742

Change 548742 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Suggested edits: Load suggested edits after activation

https://gerrit.wikimedia.org/r/548742

I'm moving the task back to Ready for Development since not all specs have been implemented.
(1)

Once the user initiates the suggested edits module and completes the overlays, the submodule about suggested edits should remain in the start module. It should not disappear like on desktop.

The current display matches the behavior on the desktop:

(2)

The submodule should remain there with its icon becoming a green checkmark, just like the other modules in their completed state. Mockup here.

The submodule for suggested edits is not present.


(3)

The submodule should also remain in the start module preview card on the homepage, but its header should change from "Start editing" to "See suggested edits".

Not done yet.

Change 551947 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/extensions/GrowthExperiments@master] Newcomer tasks: do not hide completed StartEditing module on mobile

https://gerrit.wikimedia.org/r/551947

Change 551947 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Newcomer tasks: do not hide completed StartEditing module on mobile

https://gerrit.wikimedia.org/r/551947

@Tgr -- I'm testing this out now in beta, and I see these two issues:

  • After the user has initiated the SE module, and they attempt to return to it through the start module, they have to go through the overlays again. They should not get the overlays again; they should go straight to the module.
  • If the user goes through the following pattern, they end up back inside the start module:
  • Return to SE module through the start module. Go through overlays and look at SE module.
  • Close SE module. Now the user is looking at the homepage. That's fine.
  • Open the SE module from the preview card.
  • Close the SE module. Now the user is looking at the start module overlay, instead of being back on the homepage.

Change 552158 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/extensions/GrowthExperiments@master] Do not show StartEditing dialog when suggested edits are already active

https://gerrit.wikimedia.org/r/552158

Tgr added a comment.Nov 21 2019, 12:55 AM

I'm not sure I understand exactly the steps to reproduce second problem, but the patch will change the navigation behavior anyway (as the "See suggested edits" button does not reload the page anymore if the suggested edits module is already activated). Closing the suggested edits always takes you to the homepage now, as far as I can tell.

Change 552158 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Do not show StartEditing dialog when suggested edits are already active

https://gerrit.wikimedia.org/r/552158

Re-checked the following comments - the patch worked for both issues:

After the user has initiated the SE module, and they attempt to return to it through the start module, they have to go through the overlays >again. They should not get the overlays again; they should go straight to the module.

If the user goes through the following pattern, they end up back inside the start module:[...]

All specs seem to be in place

Once the user initiates the suggested edits module and completes the overlays, the submodule about suggested edits should remain in the start module. It should not disappear like on desktop.

The submodule should remain there with its icon becoming a green checkmark, just like the other modules in their completed state

The submodule should also remain in the start module preview card on the homepage, but its header should change from "Start editing" to "See suggested edits".

The suggested edits module preview should appear immediately below the start module.

The initial stateThe activated state

This is working as expected for me as well. The style updates will be tackled in the mobile style ticket (T239442).

Initial
Activated
MMiller_WMF closed this task as Resolved.Dec 10 2019, 2:02 AM
MMiller_WMF claimed this task.

Thank you!