Page MenuHomePhabricator

[Regression] ICONS: Not compatible with truncated text (last modified and logout button)
Closed, ResolvedPublic

Description

Problem: when truncating text that contains an icon, an elipsis shows and the text is hidden. This impacts the last modified bar and the logout button

Device: iPhone 5 emulated
Modes: Stable + AMC


Last modified text is only readable at desktop/tablet resolution.

Acceptance

  • CSS only solution (to avoid caching problems)

QA

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 12 2019, 10:47 PM
Jdlrobson triaged this task as High priority.Sep 12 2019, 10:47 PM
Jdlrobson updated the task description. (Show Details)Sep 12 2019, 10:51 PM

I didn't catch this one during local testing as it doesn't impact usernames < 5 characters long 😱

Jdlrobson renamed this task from [Regression] ICONS: Last modified bar text is not readable at mobile resolution to [Regression] ICONS: Not compatible with truncated text (last modified and logout button).Sep 12 2019, 11:04 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson updated the task description. (Show Details)
Jdlrobson added a subscriber: Jdrewniak.
Jdlrobson updated the task description. (Show Details)Sep 12 2019, 11:18 PM

Since this following is also last-modified-bar related, I'm just gonna tack this on here.

Green bar not full width.

Change 536379 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/MinervaNeue@master] WIP: fix text truncation on last modified and login menu link

https://gerrit.wikimedia.org/r/536379

Change 536380 had a related patch set uploaded (by Jdrewniak; owner: Jdrewniak):
[mediawiki/skins/MinervaNeue@master] Fix truncated text showing through icons & last-modified bar

https://gerrit.wikimedia.org/r/536380

Opened https://phabricator.wikimedia.org/T232800 for last modified background issue - not quite the same problem.

Change 536379 abandoned by Jdlrobson:
Fix text truncation on last modified and login menu link

Reason:
Jan's touches less files https://gerrit.wikimedia.org/r/#/c/mediawiki/skins/MinervaNeue/ /536380/

https://gerrit.wikimedia.org/r/536379

The logout icon on Firefox is misaligned:

Change 536380 merged by Jdlrobson:
[mediawiki/skins/MinervaNeue@master] Fix truncated text showing through icons & last-modified bar

https://gerrit.wikimedia.org/r/536380

Edtadros reassigned this task from Edtadros to ovasileva.Sep 24 2019, 2:24 PM

Test Result

Status: ✅ PASS
OS: macOS Mojave
Browser: Chrome
Device: MBP
Emulated Device: iPhoneX, iPhone 5/SE

Test Artifact(s):

QA Steps:
✅ AC1: Last modified with icon and ellipsis.

✅ AC2: Long username with icon and ellipsis.

ovasileva closed this task as Resolved.Sep 25 2019, 9:02 AM

Looks good, resolving