Page MenuHomePhabricator

[Regression] ICONS "Close" text appears below close icon when loading editor overlay
Closed, ResolvedPublicBUG REPORT

Description

Steps to reproduce

  1. Go to an editable article and click the edit icon
  2. Editing overlay loads. Notice that "Close" text shows below close icon and icon is not centered

Expected results

  • "Close" text does not appear and icon is centered in header

Actual results

  • "Close" text appears and icon is not centered

Check any additional observations

QA Results

ACStatusDetails
1T232798#5506616

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : mastermobile.init/fakeToolbar: Update styles for icon changes

Event Timeline

nray created this task.Sep 12 2019, 11:39 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 12 2019, 11:39 PM
nray renamed this task from [Regression] to [Regression] "Close" text appears below close icon when loading editor overlay.Sep 12 2019, 11:39 PM
nray updated the task description. (Show Details)
nray added a comment.Sep 12 2019, 11:50 PM

Looks like Jon and I made a ticket for this at the same time:

https://phabricator.wikimedia.org/T232799

nray closed this task as Invalid.Sep 12 2019, 11:50 PM
Jdlrobson renamed this task from [Regression] "Close" text appears below close icon when loading editor overlay to [Regression] ICONS "Close" text appears below close icon when loading editor overlay.Sep 13 2019, 12:00 AM
Jdlrobson triaged this task as High priority.
matmarex claimed this task.Sep 13 2019, 1:11 AM

Change 536386 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] mobile.init/fakeToolbar: Update styles for icon changes

https://gerrit.wikimedia.org/r/536386

Change 536386 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] mobile.init/fakeToolbar: Update styles for icon changes

https://gerrit.wikimedia.org/r/536386

alexhollender added a subscriber: alexhollender.

There is still an issue with this element, however the issue described in the task has been fixed so I suggest we close this and I will open a new task to address the gap at the bottom of the header, which may be related to T215426, and the fact that the "Loading" element is not vertically centered.

Edtadros reassigned this task from Edtadros to ovasileva.Sep 19 2019, 3:34 PM
Edtadros added a subscriber: Edtadros.

Test Result

Status: ✅ PASS
OS: macOS Mojave
Browser: Chrome
Device: MBP
Emulated Device: iPhoneX, Galaxy S5, iPad Pro, Google Pixel 2, Galaxy Note 3

Test Artifact(s):
✅ AC1 - Login button is centered in container.

Edtadros updated the task description. (Show Details)Sep 19 2019, 3:35 PM
ovasileva closed this task as Resolved.Sep 20 2019, 9:16 AM