Page MenuHomePhabricator

Hide `Restore autoconfirmed status` on Special:AbuseFilter/tools if user lacks rights
Closed, ResolvedPublic

Description

It should be hidden if the user does not have abusefilter-modify rights, since they restore autoconfirmed status

After T232884: Don't allow restoring autopromotion by blocked users, it should also be hidden if the user is sitewide blocked

Event Timeline

Restricted Application added a project: User-DannyS712. · View Herald TranscriptSep 13 2019, 6:11 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
DannyS712 moved this task from Backlog to Management UI on the AbuseFilter board.

Oh didn't see you assigned it to yourself. I already have a patch if you don't.

DannyS712 updated the task description. (Show Details)Sep 13 2019, 6:34 PM

After T232884: Don't allow restoring autopromotion by blocked users is merged, I intend to resolve this by checking AbuseFilter::canEdit to determine if the interface should be shown, since that will cover both those without rights and those with rights but who are blocked from using them

After T232884: Don't allow restoring autopromotion by blocked users is merged, I intend to resolve this by checking AbuseFilter::canEdit to determine if the interface should be shown, since that will cover both those without rights and those with rights but who are blocked from using them

Yeah, that's what I did. I'm gonna send it, but I can review yours if you've already written it.

Change 536662 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@master] Don't show the form for restoring autopromotion to unprivileged users

https://gerrit.wikimedia.org/r/536662

Great minds...

Change 536662 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@master] Don't show the form for restoring autopromotion to unprivileged users

https://gerrit.wikimedia.org/r/536662

Daimona closed this task as Resolved.Sep 15 2019, 11:33 AM
Daimona removed a project: Patch-For-Review.