Page MenuHomePhabricator

[Regression] Showing "No change in size" wrongly on Minerva diff pages and text enlarged
Closed, ResolvedPublicBUG REPORT

Description

Regression caused by: T231613 and T229440

After the recent update there have been a lot of changes can be seen in the diff pages. But it produced several bugs. Changes in size is being shown wrongly on diff pages. It is happening on every site where AMC mode is not enabled, it seems.
Update: This is affecting every users at the moment (including AMC users).

Steps to Reproduce:

Actual Results:

  • It is shown that there is no change in size below the "Revision as of {{timestamp}}".
  • The text of the user info is enlarged.

Expected Results:

  • The "real" change are shown below the "Revision as of {{timestamp}}".

Screenshot:

  • The text fits the user info drawer.

QA steps

Test this on the beta cluster and check the 3 possible states have the correct icon and label:

  • Should show as bytes added:

https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileDiff/397129

  • Zero bytes changed:

https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileDiff/397299

  • Bytes removed:

https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileDiff/397130

  • Similarly the date next to bytes changed should be the same size as the label alongside the "bytes changed" icon text.

QA Results

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 15 2019, 12:21 AM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptSep 15 2019, 12:25 AM
Masumrezarock100 renamed this task from Showing "No change in size" wrongly in Minerva diff page on Wikimedia Commons to Showing "No change in size" wrongly on Minerva diff pages on Wikimedia Commons.Sep 15 2019, 12:31 AM
Masumrezarock100 updated the task description. (Show Details)

Note:
This bug is not present on the diff pages on English Wikipedia. It is showing as usual. (eg, https://en.m.wikipedia.org/wiki/Special:MobileDiff/915730353 )

Screenshot

Masumrezarock100 renamed this task from Showing "No change in size" wrongly on Minerva diff pages on Wikimedia Commons to Showing "No change in size" wrongly on Minerva diff pages on sites where AMC mode is not enabled.Sep 15 2019, 5:56 PM
Masumrezarock100 updated the task description. (Show Details)
Masumrezarock100 edited projects, added Readers-Web-Backlog; removed MobileFrontend.
Masumrezarock100 moved this task from Backlog to Bugs on the MinervaNeue board.Sep 15 2019, 6:04 PM

Change 536710 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Address Special:MobileDiff text and bytes changed regressions

https://gerrit.wikimedia.org/r/536710

Change 536710 merged by Jdlrobson:
[mediawiki/extensions/MobileFrontend@master] Address Special:MobileDiff text and bytes changed regressions

https://gerrit.wikimedia.org/r/536710

Note:
This bug is not present on the diff pages on English Wikipedia. It is showing as usual. (eg, https://en.m.wikipedia.org/wiki/Special:MobileDiff/915730353 )

Screenshot

I am not sure why but I'm seeing the bug on that very diff.

And in fact, the bug now appears everywhere on whole English Wikipedia for me.

Masumrezarock100 renamed this task from Showing "No change in size" wrongly on Minerva diff pages on sites where AMC mode is not enabled to Showing "No change in size" wrongly on Minerva diff pages when AMC mode is not enabled.Sep 16 2019, 5:00 PM
Masumrezarock100 updated the task description. (Show Details)
Masumrezarock100 added a subscriber: Jdlrobson.EditedSep 16 2019, 5:07 PM

@Ammarpad It seems this bug is appearing in every diff if AMC mode is not enabled (regardless of AMC's availability). I've updated the description. :) Jdlrobson has merged the patch, so you will see the change after the new Mediawiki version release.

Jdlrobson renamed this task from Showing "No change in size" wrongly on Minerva diff pages when AMC mode is not enabled to [Regression] Showing "No change in size" wrongly on Minerva diff pages when AMC mode is not enabled.Sep 16 2019, 5:08 PM
Jdlrobson claimed this task.
Jdlrobson added a project: Regression.

Will add some QA instructions.

Jdlrobson updated the task description. (Show Details)Sep 16 2019, 5:10 PM
Jdlrobson updated the task description. (Show Details)Sep 16 2019, 5:47 PM

Thanks for flagging this @Masumrezarock100 !

Masumrezarock100 renamed this task from [Regression] Showing "No change in size" wrongly on Minerva diff pages when AMC mode is not enabled to [Regression] Showing "No change in size" wrongly on Minerva diff pages.Sep 16 2019, 6:24 PM
Masumrezarock100 updated the task description. (Show Details)

This is affecting every users at the moment.

Change 537177 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Follow up to diff pages

https://gerrit.wikimedia.org/r/537177

Jdlrobson updated the task description. (Show Details)Sep 16 2019, 7:06 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson updated the task description. (Show Details)

Change 537177 merged by Jdlrobson:
[mediawiki/extensions/MobileFrontend@master] Follow up to diff pages text sizing and icon positioning

https://gerrit.wikimedia.org/r/537177

Jdlrobson reassigned this task from Jdlrobson to Edtadros.Sep 16 2019, 9:45 PM

Please leave at least 30 minutes from now before QAing.

Jdlrobson renamed this task from [Regression] Showing "No change in size" wrongly on Minerva diff pages to [Regression] Showing "No change in size" wrongly on Minerva diff pages and text enlarged.Sep 17 2019, 1:06 AM
Jdlrobson updated the task description. (Show Details)
ovasileva moved this task from Needs triage to Triaged on the Mobile board.Sep 17 2019, 3:29 PM
Edtadros reassigned this task from Edtadros to ovasileva.Sep 20 2019, 1:27 PM
Edtadros added a subscriber: Edtadros.

Test Result

Status: ✅ PASS
OS: macOS Mojave
Browser: Chrome
Device: MBP
Emulated Device: iPhoneX

Test Artifact(s):

QA steps

Test this on the beta cluster and check the 3 possible states have the correct icon and label:

✅ AC1: Should show as bytes added:
https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileDiff/397129

Logged OffLogged On - AMC OffLogged On - AMC On

✅ AC2: Zero bytes changed:
https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileDiff/397299

Logged OffLogged On - AMC OffLogged On - AMC On

✅ AC3: Bytes removed:
https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileDiff/397130

Logged OffLogged On - AMC OffLogged On - AMC On

✅ AC4: Confirm on https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileDiff/397299 that text for user groups is capitalized, looks like this:

Logged OffLogged On - AMC OffLogged On - AMC On

✅ AC5: Similarly the date next to bytes changed should be the same size as the label alongside the "bytes changed" icon text.

Logged OffLogged On - AMC OffLogged On - AMC On
Edtadros updated the task description. (Show Details)Sep 20 2019, 1:28 PM
ovasileva closed this task as Resolved.Sep 23 2019, 9:02 AM

Looks good.