Page MenuHomePhabricator

[AMC] Summary in recent changes misaligned
Closed, ResolvedPublic3 Story PointsBUG REPORT

Description

When I go to recent changes on srwiki via mobile, I see to for deleted pages is shown firstly is (summary) deleted page (name of page).

QA steps

e.g. NOT like this:

e.g. Like this

Developer notes

.comment element can appear inside .mw-changeslist-log-entry and when it does you don't want to pad it and float it as we currently do.

Sample row looks like this:

<li data-mw-logid="147745" data-mw-logaction="delete/delete" data-mw-ts="20190918222338" class="mw-changeslist-line mw-changeslist-log mw-changeslist-log-delete mw-changeslist-line-not-watched mw-changeslist-ns-0 mw-changeslist-ns-subject mw-changeslist-user-registered mw-changeslist-user-experienced mw-changeslist-self mw-changeslist-human mw-changeslist-major mw-changeslist-previous mw-changeslist-src-mw-log mw-changeslist-notwatched mw-line-even"><div class="mw-rcfilters-ui-highlights"><div class="mw-rcfilters-ui-highlights-color-none" data-color="none"></div><div class="mw-rcfilters-ui-highlights-color-c1" data-color="c1"></div><div class="mw-rcfilters-ui-highlights-color-c2" data-color="c2"></div><div class="mw-rcfilters-ui-highlights-color-c3" data-color="c3"></div><div class="mw-rcfilters-ui-highlights-color-c4" data-color="c4"></div><div class="mw-rcfilters-ui-highlights-color-c5" data-color="c5"></div></div><span class="mw-changeslist-line-inner" data-target-page="Testing Move 2 Selenium Echo mention test 0.13476199569104108"><span class="mw-changeslist-links"><a href="/wiki/Special:Log/delete" title="Special:Log/delete">Deletion log</a></span>; <span class="mw-changeslist-date">22:23</span> <span class="mw-changeslist-separator"></span> <span class="mw-changeslist-log-entry"><a href="/wiki/User:Jdlrobson" class="mw-userlink" title="User:Jdlrobson"><bdi>Jdlrobson</bdi></a> <span class="mw-usertoollinks mw-changeslist-links"><span><a href="/wiki/User_talk:Jdlrobson" class="mw-usertoollinks-talk" title="User talk:Jdlrobson">talk</a></span> <span><a href="/wiki/Special:Contributions/Jdlrobson" class="mw-usertoollinks-contribs" title="Special:Contributions/Jdlrobson">contribs</a></span> <span><a href="/wiki/Special:Block/Jdlrobson" class="mw-usertoollinks-block" title="Special:Block/Jdlrobson">block</a></span></span> deleted page <a href="/w/index.php?title=Testing_Move_2_Selenium_Echo_mention_test_0.13476199569104108&amp;action=edit&amp;redlink=1" class="new" title="Testing Move 2 Selenium Echo mention test 0.13476199569104108 (page does not exist)">Testing Move 2 Selenium Echo mention test 0.13476199569104108</a> &lrm;<span class="comment">(YOLO)</span></span></span></li>

.
Fix is something like this:

.mw-changeslist-log-entry .comment {
    float: none !important;
    display: inline;
}

QA Results

ACStatusDetails
1T232955#5536234

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 15 2019, 5:35 PM
Zoranzoki21 updated the task description. (Show Details)Sep 15 2019, 5:42 PM
Restricted Application added a subscriber: Petar.petkovic. · View Herald TranscriptSep 15 2019, 5:42 PM

@Zoranzoki21 Is it happening when AMC mode is enabled or not enabled?

@Zoranzoki21 Is it happening when AMC mode is enabled or not enabled?

It is with enabled AMC mode, so I set in title of task already to you know it.

It is with enabled AMC mode, so I set in title of task already to you know it.

Sorry, I didn't look at the title. I am adding AMC project tag.

I can reproduce this too on srwiki beta.wmflabs

@Zoranzoki21 I' trying to understand what the problem is. Is it

  1. that the summary is not aligned with the rest of the text, like in this screenshot:

Or

  1. Are the words in the wrong order?

@Zoranzoki21 I' trying to understand what the problem is. Is it

  1. that the summary is not aligned with the rest of the text, like in this screenshot:


Or

  1. Are the words in the wrong order?

And 1 and 2.

@Zoranzoki21 is this the correct order of the words?
(summary) is deleted page (name of page).


please correct me if it is not.

Zoranzoki21 added a comment.EditedSep 17 2019, 10:19 AM

@Zoranzoki21 is this the correct order of the words?
(summary) is deleted page (name of page).


please correct me if it is not.

No. Correct order is: is deleted page (name of page) (summary)

Masumrezarock100 added a comment.EditedSep 17 2019, 10:24 AM

@Zoranzoki21 Are you sure it is being displayed in a wrong order?

Zoranzoki21 added a comment.EditedSep 17 2019, 10:29 AM

@Zoranzoki21 Are you sure it is being displayed in a wrong order?

@Masumrezarock100 In your screenshot order looks good. And I am now confused.

That's a screenshot from the deletion log page. @Zoranzoki21 , the recent changes does look wrong. (sorry but it's easier for me to spot the problem on enwiki)
I think this summarizes it:

That's a screenshot from the deletion log page. @Zoranzoki21 , the recent changes does look wrong. (sorry but it's easier for me to spot the problem on enwiki)
I think this summarizes it:

Yes, it is. enwiki is much easier to debug 🙂 but ok, we found to it is really bug.

Zoranzoki21 changed the subtype of this task from "Task" to "Bug Report".Sep 17 2019, 10:33 AM

Yeah, that screenshot is from the deletion log.

ovasileva set the point value for this task to 3.Thu, Sep 19, 6:03 PM
Zoranzoki21 raised the priority of this task from Normal to Needs Triage.Thu, Sep 19, 6:10 PM
Zoranzoki21 triaged this task as Normal priority.

Oh wrong button on phone.. Sorry

Change 539577 had a related patch set uploaded (by Nray; owner: Nray):
[mediawiki/skins/MinervaNeue@master] Fix Recent Changes Comment alignment on deleted pages

https://gerrit.wikimedia.org/r/539577

Change 539577 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Fix Recent Changes Comment alignment on deleted pages

https://gerrit.wikimedia.org/r/539577

Much better 🙂

nray updated the task description. (Show Details)Mon, Sep 30, 3:51 PM
nray reassigned this task from nray to Edtadros.Mon, Sep 30, 5:09 PM
nray added a subscriber: nray.
Edtadros reassigned this task from Edtadros to ovasileva.Mon, Sep 30, 10:48 PM
Edtadros added a subscriber: Edtadros.

Test Result

Status: ✅ PASS
OS: macOS Mojave
Browser: Chrome
Device: MBP
Emulated Device: iPhoneX

Test Artifact(s):

QA steps

Ask someone to delete a page on beta cluster with the edit summary YOLO (@Jdlrobson can do this for you)
Visit https://en.wikipedia.beta.wmflabs.org/w/index.php?title=Special:RecentChanges
✅ AC1: (YOLO) should be aligned with rest of line and at end:

Edtadros updated the task description. (Show Details)Mon, Sep 30, 10:48 PM
ovasileva closed this task as Resolved.Tue, Oct 1, 10:48 AM