Page MenuHomePhabricator

Wikibase Travis CI builds failing after change to PHP version requirement of MediaWiki
Closed, ResolvedPublic

Description

https://gerrit.wikimedia.org/r/c/mediawiki/core/+/516829 changed the PHP (non-HHVM) version required to >= 7.2
Wikibase Travis CI builds are still running PHP 7.0 and 7.1, and have been failing since the change in "upstream" mediawiki.

Travis CI config should be change to adapt to the change (apart from 7.2, running on 7.3 might also be intended)

From the failing https://travis-ci.org/wikimedia/mediawiki-extensions-Wikibase/jobs/585927281 for example:

Error: You might be using an older PHP version (PHP 7.0.25). 

MediaWiki 1.34 needs PHP 7.2.0 or higher or HHVM version 3.18.5.

Details

Related Gerrit Patches:
mediawiki/extensions/Wikibase : masterTravis: No longer test PHP 7.0/7.1

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 17 2019, 8:33 AM
WMDE-leszek triaged this task as High priority.Sep 17 2019, 8:33 AM
WMDE-leszek updated the task description. (Show Details)

Change 537346 had a related patch set uploaded (by WMDE-leszek; owner: Hoo man):
[mediawiki/extensions/Wikibase@master] Travis: No longer test PHP 7.0/7.1

https://gerrit.wikimedia.org/r/537346

Change 537346 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Travis: No longer test PHP 7.0/7.1

https://gerrit.wikimedia.org/r/537346