Page MenuHomePhabricator

[Regression pre-wmf.24] Cannot add a gallery, and cannot make any edit afterwards
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Open VE
  2. Go to Insert>Gallery
  3. Add some images to the dialog.
  4. Click on "Insert"

It says, "Something went wrong", after dismissing the dialog, if I go back to CE, there is no cursor when I click somewhere in that document, so can't make any more edit in that session

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 17 2019, 11:29 PM

@Ryasmeen I seem to be getting a similar, but slightly different version of what you're experiencing...

Actual behavior

  1. Go to https://en.wikipedia.beta.wmflabs.org/wiki/Dog
  2. Open VE
  3. Insert > Gallery
  4. Enter "C" into "Search for media" field
  5. Select image
  6. Click "+ Add new image"
  7. Select another image
  8. Click "Apply changes"

❗️"Something went wrong" appears

  1. Click "Dismiss"
  2. Click "X" to exit "Gallery" dialog
  3. 2 images added in "Gallery" dialog appear in article
  4. Cursor is present, I enter text within the article
  5. Text appears within article
  6. Click "Publish changes..."

❗️Nothing happens

ppelberg triaged this task as High priority.Sep 17 2019, 11:44 PM
ppelberg edited projects, added VisualEditor (Current work); removed VisualEditor.
ppelberg raised the priority of this task from High to Unbreak Now!.Sep 17 2019, 11:52 PM

Changing the status considering how, in my experience, this issue blocks contributors from saving their edits. Thank you @Ryasmeen for making this clear.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptSep 17 2019, 11:52 PM

This one was a pain to track, but it's a caught-and-swallowed exception inside TreeModifier. (Swallowed because it occurs in a jQuery promise, where exceptions are discarded.)

Error: Expected
[{"type":"mwTransclusionInline","attributes":{"mw":{"parts":[{"template":{"target":{"wt":"cite journal","href":"./Template:Cite_journal"},"params":{"title":{"wt":"Origin, genetic diversity, and genome structure of the domestic dog."},"author":{"wt":"Wayne, R.K. and Ostrander, E.A."},"journal":{"wt":"BioEssays"},"volume":{"wt":"21"},"pages":{"wt":"247–257"},"url":{"wt":"http://parkinson.cos.ucf.edu/Courses/PCB6677/pdf/bioassay_dog.pdf"},"year":{"wt":"1999"}},"i":0}}]}},"originalDomElementsHash":"hed4d4ce3e5a609c7"},{"type":"/mwTransclusionInline"}]
but got
[{"type":"mwTransclusionInline","attributes":{"mw":{"parts":[{"template":{"target":{"wt":"cite journal","href":"./Template:Cite_journal"},"params":{"title":{"wt":"Origin, genetic diversity, and genome structure of the domestic dog."},"author":{"wt":"Wayne, R.K. and Ostrander, E.A."},"journal":{"wt":"BioEssays"},"volume":{"wt":"21"},"pages":{"wt":"247–257"},"url":{"wt":"http://parkinson.cos.ucf.edu/Courses/PCB6677/pdf/bioassay_dog.pdf"},"year":{"wt":"1999"}},"i":0}}]},"originalMw":"{\"parts\":[{\"template\":{\"target\":{\"wt\":\"cite journal\",\"href\":\"./Template:Cite_journal\"},\"params\":{\"title\":{\"wt\":\"Origin, genetic diversity, and genome structure of the domestic dog.\"},\"author\":{\"wt\":\"Wayne, R.K. and Ostrander, E.A.\"},\"journal\":{\"wt\":\"BioEssays\"},\"volume\":{\"wt\":\"21\"},\"pages\":{\"wt\":\"247–257\"},\"url\":{\"wt\":\"http://parkinson.cos.ucf.edu/Courses/PCB6677/pdf/bioassay_dog.pdf\"},\"year\":{\"wt\":\"1999\"}},\"i\":0}}]}"},"originalDomElementsHash":"h56bf4ce8dae5f62e"},{"type":"/mwTransclusionInline"}]
checkEqual (ve.dm.TreeModifier.js?bfcae:291)
ve.dm.TreeModifier.static.applyTreeOperation (ve.dm.TreeModifier.js?bfcae:306)
ve.dm.TreeModifier.static.applyTreeOperations (ve.dm.TreeModifier.js?bfcae:106)
ve.dm.TreeModifier.process (ve.dm.TreeModifier.js?bfcae:358)
ve.dm.TransactionProcessor.process (ve.dm.TransactionProcessor.js?cd715:111)
ve.dm.Document.commit (ve.dm.Document.js?afe84:341)
ve.dm.Surface.changeInternal (ve.dm.Surface.js?26ff7:950)
ve.dm.Surface.change (ve.dm.Surface.js?26ff7:918)
ve.ui.MWGalleryDialog.insertOrUpdateNode (ve.ui.MWGalleryDialog.js?5dac8:1081)
(anonymous) (ve.ui.MWGalleryDialog.js?5dac8:599)
(anonymous) (Process.js:62)
mightThrow (jquery.js?6fb03:3535)
process (jquery.js?6fb03:3603)
setTimeout (async)
(anonymous) (jquery.js?6fb03:3641)
fire (jquery.js?6fb03:3269)
add (jquery.js?6fb03:3328)
(anonymous) (jquery.js?6fb03:3661)
jQuery.Deferred (jquery.migrate.js?cacf7:616)
then (jquery.js?6fb03:3646)
OO.ui.Process.execute (Process.js:99)
OO.ui.Dialog.executeAction (Dialog.js:346)
OO.ui.ProcessDialog.executeAction (ProcessDialog.js:222)
OO.ui.Dialog.onActionClick (Dialog.js:163)
OO.EventEmitter.emit (oojs.jquery.js?f1afe:877)
OO.EventEmitter.emit (oojs.jquery.js?f1afe:877)
OO.ui.mixin.ButtonElement.onClick (ButtonElement.js:153)
dispatch (jquery.js?6fb03:5184)
elemData.handle (jquery.js?6fb03:4992)
matmarex moved this task from Inbox to High Priority on the Editing QA board.Sep 18 2019, 8:00 PM
Ryasmeen edited projects, added Verified; removed Editing QA.Sep 18 2019, 10:28 PM
Ryasmeen moved this task from QA to Product owner review on the VisualEditor (Current work) board.
ppelberg closed this task as Resolved.Wed, Oct 23, 1:10 AM
ppelberg claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptWed, Oct 23, 1:10 AM