Page MenuHomePhabricator

Edits in articles result in erasure of references (due to "Use My Words" third-party Chrome extension)
Closed, InvalidPublicBUG REPORT

Description

Steps to Reproduce:
Recently on Portuguese Wikipedia, I made minor edits in the articles Timerosal, section Autismo, and Dialeto recifense. In the former, I replaced the phrase "incidências de autismo" (autism occurrences) by "diagnósticos de autismo" (autism diagnoses), and in the latter, I only added a "carece de fontes" (sources needed) predefinition.
I used the Classic Editor (for source code editing). In Wikipedia test page, even on safe mode, (https://test2.wikipedia.org/w/index.php?title=References_test_page&action=edit&safemode=1), the <ref> tags and everything inside them simply vanish even before I start editing. Clicking "Publish changes" will utterly eliminate all references.

Actual Results:
Those minor edits actually resulted in erasure of all references of the Timerosal#Autismo section and of the article Dialeto Recifense, and I received two "last warnings" of a Wikipédia moderator attributing vandalism to me.
Links to problematic differences:
https://pt.wikipedia.org/w/index.php?title=Dialeto_recifense&diff=56265310&oldid=56264919
https://pt.wikipedia.org/w/index.php?title=Timerosal&diff=56273214&oldid=56272155

Even on safe mode (tested on test2.wikipedia.org), the <ref> tags and everything inside them simply vanish even before I start editing.

Expected Results:
Simply the minor edits, without any damage to references of those articles. On edit page, the <ref> tag and the content inside it should appear normally and be editable.

Update: I discovered the source of the problem: the third-party Chrome extension "Use My Words". Disabling it makes the <ref>tags appear again and allows me to normally edit any non-blocked article and save them with no damage. In other words, the bug is not on Wikimedia/Wikipedia, but in a glitched Chrome extension. So this topic can be closed.

Event Timeline

Robfbms created this task.Sep 18 2019, 7:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 18 2019, 7:38 PM
Robfbms renamed this task from Minor edits in articles resulted in erasure of references to Portuguese Wikipedia: Minor edits in articles resulted in erasure of references.Sep 18 2019, 7:42 PM
Robfbms updated the task description. (Show Details)
Aklapper changed the task status from Open to Stalled.Sep 18 2019, 8:48 PM

Hi @Robfbms, thanks for taking the time to report this and welcome to Wikimedia Phabricator!

Unfortunately this report lacks some information. If you have time and can still reproduce the problem: Please add a more complete description to this report, including links to the problematic diffs, and which editor software you used.
If you can reproduce the problem, you could also check if the problem happens when using safemode.

You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

Robfbms updated the task description. (Show Details)Sep 18 2019, 9:18 PM

Hi @Robfbms, thanks for taking the time to report this and welcome to Wikimedia Phabricator!
Unfortunately this report lacks some information. ...

Thanks, I have added the requested informations.

Aklapper added a comment.EditedSep 18 2019, 9:54 PM

@Robfbms: Thanks. What is "the default Wikipedia article editor"? Please see https://www.mediawiki.org/wiki/Editor Okay, I guess that means the 2003 one.

@Robfbms: Thanks. What is "the default Wikipedia article editor"? Please see https://www.mediawiki.org/wiki/Editor Okay, I guess that means the 2003 one.

It's the source code article editor (I almost never use the visual editor).

Robfbms updated the task description. (Show Details)Sep 18 2019, 10:06 PM
Robfbms added a comment.EditedSep 21 2019, 3:53 PM

Hello, did you find out and fix that bug?
If it is not an actual bug, what else may have caused that trouble, since I never had any intention and reason to vandalize article references?

The fear of probable recurrence of that problem and the danger of it rendering my account blocked is making me feel too insecure to make good edits to Wikipedia articles.

See my previous question:

If you can reproduce the problem, you could also check if the problem happens when using safemode.

This comment was removed by Robfbms.
Robfbms added a comment.EditedSep 21 2019, 5:10 PM

I just found References test page in test2.wikipedia.org:
https://test2.wikipedia.org/wiki/References_test_page

When I open Classic Editor to edit the article, the reference just vanishes even before I start editing it. Soon I will add the debug results.

Robfbms updated the task description. (Show Details)Sep 21 2019, 5:26 PM

Description updated with the debug results. The problem happens even on safe mode.

Robfbms updated the task description. (Show Details)Sep 21 2019, 5:46 PM
Robfbms updated the task description. (Show Details)Sep 21 2019, 6:35 PM
Aklapper renamed this task from Portuguese Wikipedia: Minor edits in articles resulted in erasure of references to Edits in articles result in erasure of references (due to "Use My Words" third-party Chrome extension).Sep 21 2019, 6:48 PM
Aklapper closed this task as Invalid.