Page MenuHomePhabricator

Welcome survey responses not stored on the first submit
Closed, ResolvedPublic

Description

The issue exists on testwiki (and betalabs), but does not exist in cswiki.

  1. On testwiki find or create a test user who was not presented with a welcome survey

e.g. to verify that a user who did not have a welcome survey:

mysql:research@dbstore1004.eqiad.wmnet [testwiki]> select * from user_properties  where up_value like "%exp2_target_specialpage%"and up_user=30833 \G
Empty set (0.01 sec)
  1. Using Special:WelcomeSurvey?group=exp2_target_specialpage in url, select some answers and submit
    • you'll be redirected to the Main page
    • db will record
mysql:research@dbstore1004.eqiad.wmnet [testwiki]> select * from user_properties  where up_value like "%exp2_target_specialpage%"and up_user=30833 \G
*************************** 1. row ***************************
    up_user: 30833
up_property: welcomesurvey-responses
   up_value: {"_group":"exp2_target_specialpage","_render_date":"20190918205837","_submit_date":"20190918205939","_counter":1}
1 row in set (0.00 sec)
  1. Return to the Special:WelcomeSurvey page and re-submit (click again on Finish button):
mysql:research@dbstore1004.eqiad.wmnet [testwiki]> select * from user_properties  where up_value like "%exp2_target_specialpage%"and up_user=30833 \G
*************************** 1. row ***************************
    up_user: 30833
up_property: welcomesurvey-responses
   up_value: {"reason":"edit-info","edited":"yes-few","topics":[],"topics-other-js":[],"mentor":false,"_group":"exp2_target_specialpage","_render_date":"20190918205837","_submit_date":"20190918210124","_counter":2}
1 row in set (0.00 sec)

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : masterSelenium: Add regression test for NONE group survey submission
mediawiki/extensions/GrowthExperiments : masterWelcomeSurvey: Fix saving results when group is overridden

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 18 2019, 9:19 PM
Etonkovidova updated the task description. (Show Details)Sep 18 2019, 9:20 PM
Catrope claimed this task.Sep 18 2019, 9:39 PM
Catrope triaged this task as Unbreak Now! priority.
Catrope edited projects, added Growth-Team (Current Sprint); removed Growth-Team.
Catrope moved this task from Incoming to In Progress on the Growth-Team (Current Sprint) board.
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptSep 18 2019, 9:39 PM

I can reproduce this both on testwiki and locally. Rolling back GrowthExperiments to wmf.22 or wmf.21 locally didn't help, so the culprit is probably somewhere else. Going to try rolling back core next.

Catrope lowered the priority of this task from Unbreak Now! to Medium.Sep 18 2019, 10:59 PM

Turns out this only happens for users who don't get assigned to a WelcomeSurvey group (i.e. don't automatically get shown a survey after account creation), and it only affects the case where you force the survey to appear by manually navigating to Special:WelcomeSurvey with the ?group=exp2_target_specialpage parameter.

Change 537772 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] WelcomeSurvey: Fix saving results when group is overridden

https://gerrit.wikimedia.org/r/537772

Change 537772 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] WelcomeSurvey: Fix saving results when group is overridden

https://gerrit.wikimedia.org/r/537772

Change 537989 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Selenium: Add regression test for NONE group survey submission

https://gerrit.wikimedia.org/r/537989

Etonkovidova closed this task as Resolved.Sep 20 2019, 3:24 PM

Checked in betalabs.

kostajh reopened this task as Open.Sep 23 2019, 1:11 PM
kostajh moved this task from QA to Code Review on the Growth-Team (Current Sprint) board.
kostajh added a subscriber: kostajh.

Re-opening as there's a patch with a regression test attached to this task.

Change 537989 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Selenium: Add regression test for NONE group survey submission

https://gerrit.wikimedia.org/r/537989

Tgr closed this task as Resolved.Oct 2 2019, 8:22 PM