Page MenuHomePhabricator

VisualEditor needs 'editToken' replaced with 'csrfToken'
Closed, ResolvedPublic

Description

VisualEditor needs 'editToken' replaced with 'csrfToken' in a modules/ve-mw/init/ve.init.mw.Target.js file.

Event Timeline

Kizule created this task.Sep 22 2019, 3:44 PM
Kizule edited projects, added VisualEditor; removed MediaWiki-ResourceLoader.

Rebuilding my vagrant to see if that gets rid of the branching issue. Will work on this one asap.

Rebuilding my vagrant to see if that gets rid of the branching issue. Will work on this one asap.

Apparently I never noticed that somehow but it was always the case......nevermind.

Change 538429 had a related patch set uploaded (by TheSandDoctor; owner: TheSandDoctor):
[mediawiki/extensions/VisualEditor@master] VisualEditor: Replace deprecated editToken with csrfToken

https://gerrit.wikimedia.org/r/538429

TheSandDoctor triaged this task as Medium priority.Sep 22 2019, 8:28 PM
Krinkle closed this task as Resolved.Sep 23 2019, 4:41 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSep 23 2019, 4:41 AM

Change 538429 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] VisualEditor: Replace deprecated editToken with csrfToken

https://gerrit.wikimedia.org/r/538429