Reduce code duplication by reusing OutputPage::sendCacheControl from ApiMain::sendCacheHeaders.
|mediawiki/core||master||+30 -55||Refactor ApiMain to use OutputPage::sendCacheControl|
|Declined||None||T233597 Refactor ApiMain to use OutputPage::sendCacheControl|
|Resolved||dbarratt||T196575 Add block cookie for browser-based API edits (including VisualEditor & MobileFrontend)|
|Resolved||None||T233594 Allow cookie-block tracking from any uncached web request|
|Resolved||dmaza||T152462 Add cookie when blocking anonymous users|
|Invalid||dmaza||T191542 Implement event logging for IP cookie blocks to make sure it's working reasonably|
|Resolved||None||T192016 Release anon cookie blocking on test.wikipedia.org|
|Resolved||dbarratt||T192017 Enable anon cookie blocking on all Wikimedia wikis|
|Resolved||dmaza||T195930 Enable set cookie with IP/IP-Range blocks when blocking logged-out users|
|Resolved||dmaza||T196121 Enable set cookie with IP/IP-Range blocks when blocking logged-out users on itwiki|
|Declined||None||T236751 Allow OutputPage to set maxage|
|Resolved||dbarratt||T236862 Add tests to OutputPage::sendCacheControl|
Change 542134 abandoned by Krinkle:
[mediawiki/core@master] Refactor ApiMain to use OutputPage::sendCacheControl
Closing for now as original issue was addressed in other commits that have landed, and this area currently has no active steward to resource refactoring changes like these. The trade-off between re-use and locality is unclear to me here, but I'm slightly leaning toward keeping it local/inlined for easier maintenance within the API code.