Page MenuHomePhabricator

"ApiQuerySiteinfo.php: PHP Notice: Undefined offset: 118" on ko.wikisource.org
Closed, ResolvedPublic

Description

Error message
PHP Notice: Undefined offset: 118
Impact
  • The wiki in question may be suffering from various namespace-related corruptions. The Siteinfo API error is presumably just the most accessible way to trigger it.
  • The information provided to API consumers is presumably invalid or not correctly usable.
  • Logspam noise. If triggered at the "wrong" times, could abort deployments and/or cause SRE alerts.
Notes

This is the third time in less than a year that this particular kind of PHP error was caused after a deployment.

Details

Request ID
43ef5590-df35-11e9-b9e1-e7510d6f2285
Request URL
/w/api.php
Stack Trace
#0 /srv/mediawiki/php-1.34.0-wmf.23/includes/api/ApiQuerySiteinfo.php(338): MWExceptionHandler::handleError(integer, string, string, integer, array)
#1 /srv/mediawiki/php-1.34.0-wmf.23/includes/api/ApiQuerySiteinfo.php(48): ApiQuerySiteinfo->appendNamespaceAliases(string)
#2 /srv/mediawiki/php-1.34.0-wmf.23/includes/api/ApiQuery.php(255): ApiQuerySiteinfo->execute()
#3 /srv/mediawiki/php-1.34.0-wmf.23/includes/api/ApiMain.php(1599): ApiQuery->execute()
#4 /srv/mediawiki/php-1.34.0-wmf.23/includes/api/ApiMain.php(537): ApiMain->executeAction()
#5 /srv/mediawiki/php-1.34.0-wmf.23/includes/api/ApiMain.php(508): ApiMain->executeActionWithErrorHandling()
#6 /srv/mediawiki/php-1.34.0-wmf.23/api.php(87): ApiMain->execute()
#7 /srv/mediawiki/w/api.php(3): require(string)
#8 {main}

Event Timeline

Krinkle created this task.Wed, Sep 25, 1:48 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptWed, Sep 25, 1:48 AM
Krinkle added a comment.EditedWed, Sep 25, 1:49 AM

Tagging RelEng and CPT as we presumably need some kind of solution either around deployment tooling or core handling to ensure this doesn't happen again, and (for the short term) to figure out what caused it and to fix it.

Also for RelEng, as tiny retrospective, a question as to whether this should have been found through the mediawiki-new-errors Kibana dashboard. While it's likely not caused by a train deploy, it was introduced within the last 2-3 weeks and should have emerged through that somehow.

revi added a subscriber: revi.Wed, Sep 25, 8:36 AM

Latest (As far as I can recall) namespace changes on kowikisource was T183836: Create a namespace for Korean Wikisource, FYI.

Anomie added a subscriber: Anomie.Wed, Sep 25, 1:50 PM

Tagging RelEng and CPT as we presumably need some kind of solution either around deployment tooling or core handling to ensure this doesn't happen again, and (for the short term) to figure out what caused it and to fix it.

We did fix the cause of T206030 during the handling of that task.

The cause here is different: rOMWCdc1298da97da: Add Draft and Draft_talk aliases for wikis that define draft namespace added aliases for kowikisource even though that wiki doesn't define the namespaces.

Change 539134 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[operations/mediawiki-config@master] Fix Draft namespace aliases

https://gerrit.wikimedia.org/r/539134

Change 539134 merged by jenkins-bot:
[operations/mediawiki-config@master] Fix Draft namespace aliases

https://gerrit.wikimedia.org/r/539134

Mentioned in SAL (#wikimedia-operations) [2019-09-25T14:53:32Z] <anomie@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Fix Draft namespace aliases (T233770) (duration: 01m 04s)

Anomie closed this task as Resolved.Wed, Sep 25, 3:00 PM
Anomie assigned this task to Petar.petkovic.

I'm going to close this, since the misconfiguration has been resolved. If someone wants to make a separate task for trying to detect this sort of misconfiguration in CI, feel free.