Page MenuHomePhabricator

Adding or editing monolingual text fails on beta and test Wikidata
Closed, ResolvedPublic

Description

Trying at add a new statement with a monolingual string datatype fails with:
jQuery.Deferred exception: LanguageSelector is not a constructor TypeError: LanguageSelector is not a constructor
Trying to edit an existing statement (example) fails with the same error.

I suspect this might be todo with the RL terminators?

Guess if that is the case we might need to revert something soon-ish. As far as I can see it isn't broken on wikidata.org

ping @Jakob_WMDE @Ladsgroup @Rosalie_WMDE

Impact

Monolingual string values cannot be edited (currently on wikidata.beta.wmflabs.org and test.wikidata.org)

Event Timeline

Tarrow created this task.Wed, Sep 25, 12:18 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptWed, Sep 25, 12:18 PM

@Tarrow: Trying to guess a project tag for this task so others can find it. Feel free to correct.

Fails on test.wikidata.org (group0, wmf.24) too.

Lucas_Werkmeister_WMDE renamed this task from Adding a new monolingual statement fails on beta to Adding or editing monolingual text fails on beta and test Wikidata.Wed, Sep 25, 12:28 PM
Lucas_Werkmeister_WMDE updated the task description. (Show Details)

Change 539111 had a related patch set uploaded (by Jakob; owner: Jakob):
[mediawiki/extensions/Wikibase@master] Revert "Merge valueview modules"

https://gerrit.wikimedia.org/r/539111

Lydia_Pintscher triaged this task as Unbreak Now! priority.Wed, Sep 25, 1:03 PM
Lydia_Pintscher added a subscriber: Lydia_Pintscher.

Marking this as unbreak now to make sure it gets fixed and backported before the issue hits production.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptWed, Sep 25, 1:03 PM

Change 539111 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Revert "Merge valueview modules"

https://gerrit.wikimedia.org/r/539111

Change 539127 had a related patch set uploaded (by Ladsgroup; owner: Jakob):
[mediawiki/extensions/Wikibase@wmf/1.34.0-wmf.24] Revert "Merge valueview modules"

https://gerrit.wikimedia.org/r/539127

Change 539127 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@wmf/1.34.0-wmf.24] Revert "Merge valueview modules"

https://gerrit.wikimedia.org/r/539127

Seems to work again on beta, so it looks like the fix is working on master.

Mentioned in SAL (#wikimedia-operations) [2019-09-25T14:55:12Z] <ladsgroup@deploy1001> Synchronized php-1.34.0-wmf.24/extensions/Wikibase/view/lib/resources.php: Revert "Merge valueview modules": T233800 (duration: 01m 04s)

Lucas_Werkmeister_WMDE lowered the priority of this task from Unbreak Now! to High.Wed, Sep 25, 2:58 PM

And seems to be fixed on Wikidata as well, so lowering priority a bit (but leaving final verification to @Lydia_Pintscher).

Lucas_Werkmeister_WMDE closed this task as Resolved.Wed, Sep 25, 3:02 PM
Lucas_Werkmeister_WMDE assigned this task to Jakob_WMDE.

Confirmed resolved :)

@Tarrow – how did you find this, by the way? Was it caught by any tests? If no, we might want to add some…