Page MenuHomePhabricator

1.35.0-wmf.3 deployment blockers
Closed, ResolvedPublicRelease

Details

Release Version
1.35.0-wmf.3
Release Date
1571616000

2019 week 43 1.35-wmf.3 Changes wmf/1.35.0-wmf.3

This MediaWiki Train Deployment is scheduled for the week of Monday, October 21st:

Monday October 21stTuesday, October 22ndWednesday, October 23rdThursday, October 24thFriday
SWAT deployments only.Branch wmf.3 and deploy to Group 0 Wikis.Deploy wmf.3 to Group 1 Wikis.Deploy wmf.3 to all Wikis.No deployments on fridays

How this works

  • Any serious bugs affecting wmf.3 should be added as subtasks beneath this one.
  • Any open subtask(s) block the train from moving forward.This means no further deployments until the blockers are resolved.
  • If something is serious enough to warrant a rollback then you should bring it to the attention of deployers on the #wikimedia-operations IRC channel.
  • For more info about deployment blockers, see Holding the train.

Related Links

Other Deployments

Previous: 1.35.0-wmf.2
Next: 1.35.0-wmf.4

Related Objects

Event Timeline

mmodell created this task.Sep 25 2019, 10:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 25 2019, 10:14 PM
thcipriani triaged this task as Medium priority.
thcipriani added subscribers: brennen, thcipriani.

Assigning to lars with @brennen as a backup

Started the branch cut. There are some possible issues with new Gerrit, but co-workers seem confident they don't affect this. We won't know if it works until we've tried it.

Started the branch cut. There are some possible issues with new Gerrit, but co-workers seem confident they don't affect this. We won't know if it works until we've tried it.

I checked that the HEAD of all of the extensions + core on gerrit1001 are ancestors of the HEAD of their master branch on cobalt via this script:

#!/bin/bash

set -euo pipefail

while read -r REPO; do
    printf 'Checking %s...' "$REPO"
    SHA=$(ssh cobalt.wikimedia.org -- git -C /srv/gerrit/git/mediawiki/"$REPO".git for-each-ref refs/heads/master 2>/dev/null < /dev/null | awk '{print $1}')
    if ssh gerrit1001.wikimedia.org -- git -C /srv/gerrit/git/mediawiki/"$REPO".git merge-base --is-ancestor "$SHA" refs/heads/master 2>/dev/null < /dev/null; then
        printf 'Done!\n'
    else
        printf 'Problem :(\n'
    fi
done < <(jq -r '.extensions[]' < /srv/Projects/Wikimedia/mediawiki/tools/release/make-wmf-branch/config.json )

printf 'Checking core...'
SHA=$(ssh cobalt.wikimedia.org -- git -C /srv/gerrit/git/mediawiki/core.git for-each-ref refs/heads/master 2>/dev/null < /dev/null | awk '{print $1}')
if ssh gerrit1001.wikimedia.org -- git -C /srv/gerrit/git/mediawiki/core.git merge-base --is-ancestor "$SHA" refs/heads/master 2>/dev/null < /dev/null; then
    printf 'Done!\n'
else
    printf 'Problem :(\n'
fi

None reported problems; i.e., branch cut should be fine:

Checking extensions/3D...Done!
Checking extensions/AbuseFilter...Done!
Checking extensions/ActiveAbstract...Done!
Checking extensions/AdvancedSearch...Done!
Checking extensions/AntiSpoof...Done!
Checking extensions/ApiFeatureUsage...Done!
Checking extensions/ArticleCreationWorkflow...Done!
Checking extensions/ArticlePlaceholder...Done!
Checking extensions/Babel...Done!
Checking extensions/BetaFeatures...Done!
Checking extensions/BounceHandler...Done!
Checking extensions/Calendar...Done!
Checking extensions/Campaigns...Done!
Checking extensions/Capiunto...Done!
Checking extensions/CategoryTree...Done!
Checking extensions/CentralAuth...Done!
Checking extensions/CharInsert...Done!
Checking extensions/CheckUser...Done!
Checking extensions/CirrusSearch...Done!
Checking extensions/Cite...Done!
Checking extensions/CiteThisPage...Done!
Checking extensions/Citoid...Done!
Checking extensions/cldr...Done!
Checking extensions/Cognate...Done!
Checking extensions/CodeEditor...Done!
Checking extensions/CodeMirror...Done!
Checking extensions/CodeReview...Done!
Checking extensions/CollaborationKit...Done!
Checking extensions/Collection...Done!
Checking extensions/CommonsMetadata...Done!
Checking extensions/ConfirmEdit...Done!
Checking extensions/CongressLookup...Done!
Checking extensions/ContactPage...Done!
Checking extensions/ContentTranslation...Done!
Checking extensions/ContributionTracking...Done!
Checking extensions/CreditsSource...Done!
Checking extensions/Dashiki...Done!
Checking extensions/Disambiguator...Done!
Checking extensions/DismissableSiteNotice...Done!
Checking extensions/DonationInterface...Done!
Checking extensions/DoubleWiki...Done!
Checking extensions/DynamicSidebar...Done!
Checking extensions/EUCopyrightCampaign...Done!
Checking extensions/Echo...Done!
Checking extensions/Elastica...Done!
Checking extensions/ElectronPdfService...Done!
Checking extensions/EntitySchema...Done!
Checking extensions/EventBus...Done!
Checking extensions/EventLogging...Done!
Checking extensions/ExtensionDistributor...Done!
Checking extensions/ExternalGuidance...Done!
Checking extensions/FeaturedFeeds...Done!
Checking extensions/FileExporter...Done!
Checking extensions/FileImporter...Done!
Checking extensions/FlaggedRevs...Done!
Checking extensions/Flow...Done!
Checking extensions/FundraiserLandingPage...Done!
Checking extensions/FundraisingTranslateWorkflow...Done!
Checking extensions/Gadgets...Done!
Checking extensions/GeoCrumbs...Done!
Checking extensions/GeoData...Done!
Checking extensions/GettingStarted...Done!
Checking extensions/GlobalBlocking...Done!
Checking extensions/GlobalCssJs...Done!
Checking extensions/GlobalPreferences...Done!
Checking extensions/GlobalUsage...Done!
Checking extensions/GlobalUserPage...Done!
Checking extensions/GoogleNewsSitemap...Done!
Checking extensions/Graph...Done!
Checking extensions/GrowthExperiments...Done!
Checking extensions/GuidedTour...Done!
Checking extensions/GWToolset...Done!
Checking extensions/ImageMap...Done!
Checking extensions/InputBox...Done!
Checking extensions/Insider...Done!
Checking extensions/intersection...Done!
Checking extensions/Interwiki...Done!
Checking extensions/InterwikiSorting...Done!
Checking extensions/Jade...Done!
Checking extensions/Josa...Done!
Checking extensions/JsonConfig...Done!
Checking extensions/Kartographer...Done!
Checking extensions/LabeledSectionTransclusion...Done!
Checking extensions/LandingCheck...Done!
Checking extensions/LdapAuthentication...Done!
Checking extensions/Linter...Done!
Checking extensions/LiquidThreads...Done!
Checking extensions/Listings...Done!
Checking extensions/LocalisationUpdate...Done!
Checking extensions/LoginNotify...Done!
Checking extensions/MachineVision...Done!
Checking extensions/MapSources...Done!
Checking extensions/MassMessage...Done!
Checking extensions/Math...Done!
Checking extensions/MobileApp...Done!
Checking extensions/MobileFrontend...Done!
Checking extensions/MultimediaViewer...Done!
Checking extensions/NavigationTiming...Done!
Checking extensions/Newsletter...Done!
Checking extensions/NewUserMessage...Done!
Checking extensions/Nuke...Done!
Checking extensions/OATHAuth...Done!
Checking extensions/OAuth...Done!
Checking extensions/OpenStackManager...Done!
Checking extensions/ORES...Done!
Checking extensions/PageAssessments...Done!
Checking extensions/PagedTiffHandler...Done!
Checking extensions/PageImages...Done!
Checking extensions/PageTriage...Done!
Checking extensions/PageViewInfo...Done!
Checking extensions/ParserFunctions...Done!
Checking extensions/ParsoidBatchAPI...Done!
Checking extensions/PdfHandler...Done!
Checking extensions/PerformanceInspector...Done!
Checking extensions/Petition...Done!
Checking extensions/Poem...Done!
Checking extensions/PoolCounter...Done!
Checking extensions/Popups...Done!
Checking extensions/ProofreadPage...Done!
Checking extensions/PropertySuggester...Done!
Checking extensions/QuickSurveys...Done!
Checking extensions/Quiz...Done!
Checking extensions/ReadingLists...Done!
Checking extensions/RelatedArticles...Done!
Checking extensions/Renameuser...Done!
Checking extensions/RevisionSlider...Done!
Checking extensions/RSS...Done!
Checking extensions/SandboxLink...Done!
Checking extensions/Score...Done!
Checking extensions/Scribunto...Done!
Checking extensions/SearchExtraNS...Done!
Checking extensions/SecureLinkFixer...Done!
Checking extensions/SecurePoll...Done!
Checking extensions/Sentry...Done!
Checking extensions/ShortUrl...Done!
Checking extensions/SiteMatrix...Done!
Checking extensions/SkinPerPage...Done!
Checking extensions/SpamBlacklist...Done!
Checking extensions/SubPageList3...Done!
Checking extensions/SubpageSortkey...Done!
Checking extensions/SyntaxHighlight_GeSHi...Done!
Checking extensions/TemplateData...Done!
Checking extensions/TemplateSandbox...Done!
Checking extensions/TemplateStyles...Done!
Checking extensions/TemplateWizard...Done!
Checking extensions/TextExtracts...Done!
Checking extensions/Thanks...Done!
Checking extensions/TheWikipediaLibrary...Done!
Checking extensions/TimedMediaHandler...Done!
Checking extensions/timeline...Done!
Checking extensions/TitleBlacklist...Done!
Checking extensions/TocTree...Done!
Checking extensions/TorBlock...Done!
Checking extensions/Translate...Done!
Checking extensions/TranslationNotifications...Done!
Checking extensions/TrustedXFF...Done!
Checking extensions/TwoColConflict...Done!
Checking extensions/UniversalLanguageSelector...Done!
Checking extensions/UploadsLink...Done!
Checking extensions/UploadWizard...Done!
Checking extensions/UrlShortener...Done!
Checking extensions/UserMerge...Done!
Checking extensions/VipsScaler...Done!
Checking extensions/VisualEditor...Done!
Checking extensions/WebAuthn...Done!
Checking extensions/Wikibase...Done!
Checking extensions/WikibaseCirrusSearch...Done!
Checking extensions/WikibaseLexeme...Done!
Checking extensions/WikibaseLexemeCirrusSearch...Done!
Checking extensions/WikibaseMediaInfo...Done!
Checking extensions/WikibaseQualityConstraints...Done!
Checking extensions/Wikidata.org...Done!
Checking extensions/WikidataPageBanner...Done!
Checking extensions/WikiEditor...Done!
Checking extensions/wikihiero...Done!
Checking extensions/WikiLove...Done!
Checking extensions/WikimediaBadges...Done!
Checking extensions/WikimediaEditorTasks...Done!
Checking extensions/WikimediaEvents...Done!
Checking extensions/WikimediaIncubator...Done!
Checking extensions/WikimediaMaintenance...Done!
Checking extensions/WikimediaMessages...Done!
Checking extensions/XAnalytics...Done!
Checking skins/CologneBlue...Done!
Checking skins/EUCopyrightCampaignSkin...Done!
Checking skins/MinervaNeue...Done!
Checking skins/MonoBook...Done!
Checking skins/Modern...Done!
Checking skins/Nostalgia...Done!
Checking skins/Timeless...Done!
Checking skins/Vector...Done!
Checking vendor...Done!
Checking core...Done

Got as far as the scap sync of wikiversions.json to testwiki, but made a mistake and it went to labtestwiki instead, and not even there because a database failure. Train blocked. See subtask.

brennen claimed this task.Oct 22 2019, 6:42 PM
brennen added a subscriber: LarsWirzenius.

Deployed to group0, updated roadmap. Will reassign task to Lars at EOD.

brennen reassigned this task from brennen to LarsWirzenius.Oct 23 2019, 6:36 AM
brennen claimed this task.Oct 23 2019, 9:13 PM
brennen updated the task description. (Show Details)Oct 23 2019, 11:06 PM

This train is no longer blocked, and can proceed according to schedule. Handing off to @LarsWirzenius.

Deployed to all wikis. Logstash didn't explode immediately, but keeping an eye on it.

LarsWirzenius closed this task as Resolved.Oct 30 2019, 1:40 PM

I declare this train to be finished.