Page MenuHomePhabricator

Remove Special:Uploads from MobileFrontend
Closed, ResolvedPublic

Description

As discussed in https://phabricator.wikimedia.org/T232653#5519998 the Special:Uploads page bundled in MobileFrontend is not useful to editors or readers given the lack of an upload feature on mobile.

https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:ListFiles provides a suitable and more powerful alternative.

Acceptance criteria

  • Remove Special:Uploads frontend and backend code from MobileFrontend

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterRedirect Special:Uploads to Special:ListFiles
mediawiki/extensions/MobileFrontend : masterRemove Special:Uploads from MobileFrontend
mediawiki/skins/MinervaNeue : masterRemove "uploads" link from userpages in AMC mode
mediawiki/skins/MinervaNeue : masterRemove "uploads" link from userpages

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 26 2019, 7:48 PM
Ammarpad claimed this task.Sep 29 2019, 4:35 PM

Change 539718 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/extensions/MobileFrontend@master] [WIP] Remove Special:Uploads from MobileFrontend

https://gerrit.wikimedia.org/r/539718

Per https://gerrit.wikimedia.org/r/501449 (about Special:History) please make sure to keep the current canonical and localised names registered as a redirect.

Change 540001 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[mediawiki/skins/MinervaNeue@master] Remove "uploads" link from userpages

https://gerrit.wikimedia.org/r/540001

Change 540001 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Remove "uploads" link from userpages

https://gerrit.wikimedia.org/r/540001

Per https://gerrit.wikimedia.org/r/501449 (about Special:History) please make sure to keep the current canonical and localised names registered as a redirect.

OK

@Ammarpad apologies for missing this in code review, but it seems there was another link to the uploads page in Minerva:

Could you remove the "minerva-page-actions-uploads" link as well?

We'll need to fix this today or tomorrow to make sure this doesn't go out to production.

Change 540624 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/skins/MinervaNeue@master] Remove "uploads" link from userpages in AMC mode

https://gerrit.wikimedia.org/r/540624

Change 540624 merged by Jdlrobson:
[mediawiki/skins/MinervaNeue@master] Remove "uploads" link from userpages in AMC mode

https://gerrit.wikimedia.org/r/540624

Above issue now fixed. @Ammarpad I think all the blockers for https://gerrit.wikimedia.org/r/539718 are out of the way now :)

Above issue now fixed. @Ammarpad I think all the blockers for https://gerrit.wikimedia.org/r/539718 are out of the way now :)

Thanks @Jdlrobson, it appears there are still unresolved errors though.

Change 539718 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Remove Special:Uploads from MobileFrontend

https://gerrit.wikimedia.org/r/539718

Change merged:
[mediawiki/extensions/MobileFrontend@master] Remove Special:Uploads from MobileFrontend
https://gerrit.wikimedia.org/r/539718

Per https://gerrit.wikimedia.org/r/501449 (about Special:History) please make sure to keep the current canonical and localised names registered as a redirect.

By what means will existing URLs be kept functional? Should these move to core as redirecting special page? Importing the localisation is possible, but would be a lot easier if we kept this in MobileFrontend - and before the next localisation update - maybe revert if path forward is not obvious and landing soon.

Special:Uploads should redirect to Special:ListFiles. I assume that needs to be done in core?

Krinkle added a comment.EditedOct 9 2019, 9:34 PM

The page existing, its URL, and the wiki-specific canonical/localised variant of it were provided by MF and are still there now. Re-using that seems the quicker way to get this done, and avoids the url from becoming a new core-required thing (which brings up that it will become a new redirect-compat url for new wikis that never had MF installed which is not discussed here as intended side-effect. It also means we can't use that page name in the future easily. And would break any third-party extensions using that name already today.).

I don't oppose it becoming part of core eventually, it's just a more tricky thing that should be done with more care and time that we might not want to spend right now. Restoring the magic-alias parts of that commit and restoring the SpecialPage subclass as Redirecting one would solve it. If we wait until after the next sync, we'll have to piece out the parts of all localisation files and do this by hand, which will take considerably more effort.

Sounds good. I can do that if you can review.

Change 541947 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Redirect Special:Uploads to Special:ListFiles

https://gerrit.wikimedia.org/r/541947

Change 541947 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Redirect Special:Uploads to Special:ListFiles

https://gerrit.wikimedia.org/r/541947

Jdlrobson closed this task as Resolved.Oct 11 2019, 11:20 PM

hurrah!