Spotted in https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/434973/, which bumps the composer.json's PHP requirement to >=7.2.0. The job failed with the following error:
This package requires php >=7.2.0 but your PHP version (7.0.33) does not satisfy that requirement.
Can be consistently reproduced with a simple test change like https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/539572/.
For extensions, the job works properly and runs on PHP 7.2, as seen in this test.